Project

General

Profile

Bug #1218

gnome's yelp does not show oi specific man pages

Added by Michael Keller over 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2011-07-15
Due date:
2011-09-14
% Done:

0%

Estimated time:
8.00 h
Difficulty:
Bite-size
Tags:
yelp

Description

oi specific man pages (like zpool(1m) ) are neither known nor can be shown by executing:

yelp man:zpool(1m) 

-> not known

nor

yelp file:///usr/share/man/man1m/zpool.1m

-> XML parsing error

History

#1

Updated by Garrett D'Amore over 8 years ago

  • Project changed from illumos gate to OpenIndiana Distribution
#2

Updated by Chris Jordan over 8 years ago

  • Category set to Desktop (JDS)
  • Assignee set to OI JDS
  • Tags changed from needs-triage to yelp

I can reproduce this on openindiana 148 and 151. There are two separate issues with yelp displaying the man page for zpool(1M):

First, yelp doesn't know about the section 1M man pages, thus "zpool(1M)" isn't found. The 1M man pages don't show up when you start yelp and click on home/manual pages/system administration (or on any of the other manual pages sections). They also don't show up when you do a search. I suspect this is because yelp doesn't understand the openindiana/SysV man page section numbers - I found an old opensolaris bug from 2009 on this: https://defect.opensolaris.org/bz/show_bug.cgi?id=12013

Second, when you tell yelp to open the man file directly it gives an xml parsing error. In particular:

:~$ yelp file:///usr/share/man/man1m/zpool.1m

pops up a screen that says:

XML Parsing Error: not well-formed
Location: file:///usr/share/man/man1m/zpool.1m#x-yelp-index
Line Number 1020, Column 12:
</p><p>tab(ctrl-G) box;
-----------^

(well, the error shows a symbol instead of ctrl-G, but it corresponds to ctrl-G in the zpool.1m file)

I found an old opensolaris bug from 2008 which may be the same problem: https://defect.opensolaris.org/bz/show_bug.cgi?id=5063

If I edit edit zpool.1m and remove the three ctrl-G's there, then yelp is able to display the man page, although the attributes table at the end does not display correctly, so it looks like yelp will display an xml error on any man pages with ctrl-G in them.

#3

Updated by Ken Mays over 8 years ago

  • Target version set to oi_151_stable
  • Estimated time set to 8.00 h

Tested with ,5.11-0.151.1:20110910T035438Z
-> same issue as mentioned above. No upstream fix yet.

#4

Updated by Ken Mays over 8 years ago

  • Due date set to 2011-09-14
  • Status changed from New to Closed
  • Priority changed from Normal to Low
  • Difficulty changed from Medium to Bite-size

Workaround is to use man. OI JDS does not maintain yelp outside of what JDS consolidation.

#5

Updated by Ken Mays over 8 years ago

  • Status changed from Closed to Feedback
  • Target version deleted (oi_151_stable)
#6

Updated by Ken Mays about 7 years ago

  • Status changed from Feedback to Closed

This was a known problem with yelp for many years. Since this won't be fixed here, closing ticket.

Also available in: Atom PDF