Project

General

Profile

Bug #1220

gnupg executable name strangeness

Added by Josef Sipek over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
OI-Userland
Target version:
Start date:
2011-07-17
Due date:
2011-09-16
% Done:

50%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
GnuPG

Description

I installed pkg:, and to my surprise, there was no 'gpg' executable. The executable that's installed is gpg2 (in /usr/bin).

Sadly, there are many utilities (including git) that assume that gpg is called gpg, and they fail in all sort of weird ways. For example,

$ git tag -u C7958FFE foo
fatal: exec gpg failed.
error: gpg failed to sign the tag
fatal: unable to sign the tag

History

#1

Updated by Julian Wiesener over 8 years ago

  • Category set to 10
  • Assignee set to OI SFW
  • Target version set to oi_151_stable
  • Tags changed from needs-triage to GnuPG

should be easy to fix, no conficts for /usr/bin/gpg

#2

Updated by Ken Mays about 8 years ago

  • Due date set to 2011-09-14
  • Assignee changed from OI SFW to OI Userland
  • Estimated time set to 8.00 h
  • Difficulty changed from Medium to Bite-size
#3

Updated by Ken Mays about 8 years ago

  • Due date changed from 2011-09-14 to 2011-09-16
  • Status changed from New to Closed
  • Estimated time changed from 8.00 h to 1.00 h

Josef - no need for us to do anything. You can easily symlink gpg to gpgv2, this is how it is done by other distros to differentiate from gpgv1 installs so it is normal to package it this way (not a bug).

#4

Updated by Josef Sipek about 8 years ago

Note that these aren't MY scripts dying but rather well known software that we ship. For example, without this symlink, git can't sign tags, etc. I think that we should make that symlink for the user.

#5

Updated by Josef Sipek about 8 years ago

  • Status changed from Closed to Feedback
#6

Updated by Ken Mays about 8 years ago

Ok. Just pointing out that the package itself is not broken (bug). Otherwise, this sounds good to implement

#7

Updated by Josef Sipek about 8 years ago

Fair enough. Not a bug, but still an issues as far as usability of OI as a whole goes.

#8

Updated by Yuri Pankov about 8 years ago

+1, having crypto/gnupg install gpg symlink would be nice.

#9

Updated by Josef Sipek about 8 years ago

  • Assignee changed from OI Userland to Josef Sipek
  • % Done changed from 0 to 50
#10

Updated by Josef Sipek about 8 years ago

  • Category changed from 10 to 35
#11

Updated by Igor Kozhukhov about 8 years ago

some automation tools using /usr/bin/gpg and /usr/bin/gpgv

need update manifest for:
/usr/bin/gpg2 -> /usr/bin/gpg
/usr/bin/gpgv2 -> /usr/bin/gpgv

example:
link path=usr/bin/gpg target=gpg2
link path=usr/bin/gpgv target=gpgv2

#12

Updated by Josef Sipek about 8 years ago

Yeah. I already sent out version one of a patch and got some feedback. I need to address the feedback and send out a new version of the patch.

#13

Updated by Josef Sipek over 7 years ago

  • Assignee deleted (Josef Sipek)
#14

Updated by Ken Mays almost 7 years ago

  • Status changed from Feedback to Closed
  • Assignee set to Adam ┼átevko

checked: https://hg.openindiana.org/upstream/oracle/userland-gate/file/5a6584b767aa/components/gnupg/gnupg.p5m
This is not fixed upstream and not gnupg not provided in oi-build yet. This can be done by distro provider once within local repo or just added by post install script. Otherwise, there may be a very good reason not included in build by upstream so check and confirm before reopening this ticket.

Also available in: Atom PDF