Project

General

Profile

Feature #12223

Update libdwarf to libdwarf-20200612

Added by Robert Mustacchi 7 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
lib - userland libraries
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

To enable the use of newer dwarf standards and other features, I've gone ahead and updated libdwarf in gate. This also has transitioned libdwarf to using a scheme like acpica where there is now an illumos/libdwarf repo with branches corresponding to upstream releases with our patches placed on top of them.

History

#1

Updated by Electric Monk about 2 months ago

  • Gerrit CR set to 325
#2

Updated by Robert Mustacchi about 2 months ago

  • Subject changed from Update libdwarf to libdwarf-20191104 to Update libdwarf to libdwarf-20200612

The original version here with the fixes for handling relocation processing caused a regression. I worked with the follks behind libdwarf who did a bunch of work here and improved that over the intervening time. I circled back and found one or two additional issues, but with the update to our version of 20200612, things now work on those different pltaforms.

To test this I did a build of illumos-gate on debug and diffed all of the ctf before and after and had only changes to libdwarf and libctf, which matches what I'd hope and expect!

#3

Updated by Robert Mustacchi about 1 month ago

I tested this in the following ways:

  • By running the wip ctfwsdiff script that verified that the only changes in ctf between the prior version of libdwarf and htis one were in libdwarf and libctf, which is what we'd expect.
  • By running the ctf test suite on just this change. Here, with -gdwarf-2 gcc4.4.4, 7, and 8 all passed
  • I attempted parts of the ctf test suite on this with just clang, as expected it wasn't very successful (due to all the other clang improvements that are in the pipeline), but some tests passed indicating that we had solved the original .o problems
  • I had an iteration of this change with some of the older attempts with all the other clang related changes (note this was before the integration of #10854 so some of those need to be reworked) and that was generally positive.
#4

Updated by Electric Monk about 1 month ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

git commit 4d9fdb46b215739778ebc12079842c9905586999

commit  4d9fdb46b215739778ebc12079842c9905586999
Author: Robert Mustacchi <rm@fingolfin.org>
Date:   2020-07-10T19:35:15.000Z

    12223 Update libdwarf to libdwarf-20200612
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF