Project

General

Profile

Actions

Bug #12283

closed

ctfconvert hangs in libctf on C++ binaries

Added by Denis Kozadaev almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
lib - userland libraries
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The tool used as:
ctfconvert -k -l libmimelib libmimelib.so.1.0.1

libmimelib is a C++ shared library.
Under gdb I located it here:
http://src.illumos.org/source/xref/illumos-gate/usr/src/lib/libctf/common/ctf_dwarf.c#1211
every iteration memb does not change its value:
2: child = (Dwarf_Die) 0x506e60
3: memb = (Dwarf_Die) 0x506e60

tag did not change its value:
ctf_dwarf_fixup_sou (cup=0x4172c0, die=0x4fca10, base=58, add=B_FALSE) at ../common/ctf_dwarf.c:1241
1241 if (tag != DW_TAG_member)
1: ret = 0
2: memb = (Dwarf_Die) 0x506e60
3: tag = 46


Files

libmimelib.so.1.0.1.bz2 (497 KB) libmimelib.so.1.0.1.bz2 Denis Kozadaev, 2020-02-04 06:53 PM

Related issues

Is duplicate of illumos gate - Feature #12227: libctf incorrectly handles clang anonymous unionsClosedRobert Mustacchi

Actions
Actions

Also available in: Atom PDF