Project

General

Profile

Actions

Feature #12290

closed

mdb: libpython should use python3 and remove 32-bit libpython module

Added by Toomas Soome over 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdb - modular debugger
Start date:
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

mob does provide module lib python, and it is built both 32-bit and 64-bit versions, but apparently 32-bit version is provided by distributions only with python 2, and python 3 is provided only as 64-bit variant. Therefore it is reasonable to EOL 32-bit lib python module.


Related issues

Related to illumos gate - Bug #14769: remove support for Python 2.xClosedRich Lowe

Actions
Actions #1

Updated by Electric Monk about 2 years ago

  • Gerrit CR set to 365
Actions #2

Updated by Rich Lowe about 2 months ago

  • Related to Bug #14769: remove support for Python 2.x added
Actions #3

Updated by Toomas Soome about 1 month ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF