Project

General

Profile

Bug #12301

LibreCAD: run into QT5 bug QTBUG-62840

Added by Carsten Grzemba 7 days ago. Updated 4 days ago.

Status:
New
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

I attempt to build librecad with QT5 but the builded code cores at startup an see an assertion:

ASSERT failure in Q_UNREACHABLE(): "Q_UNREACHABLE was reached", file ~/oi-userland/components/library/qt5/qt-everywhere-opensource-src-5.8.0/qtbase/include/QtGui/5.8.0/QtGui/private/../../../../../src/gui/image/qimage_p.h, line 132

which seems to match with QTBUG-62840. There is mentioned it is fixed in QT5.10.

So can we uptated QT5?

History

#1

Updated by Michal Nowak 4 days ago

Updating Qt is a considerable enterprise...

I suggest you port the patch (https://codereview.qt-project.org/c/qt/qtbase/+/207740) to our version and see if it fixes the problem you encounter.

Also available in: Atom PDF