Project

General

Profile

Bug #12453

Missing shutdown log on AMD Ryzen

Added by Gary Mills 8 months ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Since approximately December 2019, the shutdown messages have disappeared on my AMD Ryzen systems. In the tests, outlined below, I powered off the system from the GUI, and observed the screen.

The first one was an Intel system, for comparison. It ran OI from March 2020. The CPU was an Intel(r) Xeon(r) W3550. The video card was a Radeon HD 2400 PRO/XT, operating at 1280x1024. On shutdown, it displayed all the console messages, starting with the last boot. At the conclusion, it powered off the system.

The next one was an AMD system. It also ran OI from March 2020. The CPU was an AMD Ryzen 3 2200G. The video card was a Radeon HD 7450, also operating at 1280x1024. On shutdown, I got a black screen, with a single white rectangle in the upper left corner. After some time, the system powered off.

The final one was another AMD system. This one had an AMD Ryzen 3 1200. The video card again was a Radeon HD 7450, operating at 1280x1024. When running OI from September 2018, it displayed all of the console messages, starting with the last boot. At the conclusion, it powered off the system.

When running OI from March 2020, it displayed only the black screen with the single white rectangle, just like the other AMD system. After some time, the system powered off.

I conclude that this problem only happens with AMD Ryzen systems, and that it used to work on these systems.

Of course, I don't know if this is an illumos problem or an OI problem. I also don't know if the illumos loader is involved. It could even be caused by the video card, although it's a recent one and used to work with OI.


Related issues

Related to illumos gate - Bug #12387: X11 fails for certain Ryzen CPUsNew

Actions
#1

Updated by Gary Mills 8 months ago

  • Related to Bug #12387: X11 fails for certain Ryzen CPUs added
#2

Updated by Gary Mills 8 months ago

I heard from Toomas Soome. The loader is not involved in shutdown, as I suspected. Toomas also suggested that the black screen I observed during shutdown was caused by improper termination of Xorg. That suggestion turned out to be correct.

The last line of /var/log/Xorg.0.log.old, on systems that displayed the shutdown messages correctly, was like this:

Server terminated successfully (0). Closing log file.

This message was printed to the log file about two seconds after the previous message.

On systems that did not display the shutdown messages, this line was missing from the Xorg log file.

I will be conducting more experiments to see why this misbehavior has happened, but in the meantime I will close this bug report and replace it with an OI-specific one. Most likely I won't be able to close this report. In that case, I'd like somebody who has that ability to close this bug report for me.

#3

Updated by Joshua M. Clulow 8 months ago

  • Status changed from New to Rejected

Closing unfixed as per request!

Also available in: Atom PDF