Project

General

Profile

Feature #12479

Uplift GntTLS from GntTLS 2.5.16 to GnuTLS 3.6.6

Added by r a 7 months ago. Updated 5 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Can GnuTLS be uplifted to version v3.6.6, a prerequisite would be to upgrade Nettle v3.5.1 (libnettle and libhogweed) so that Filezilla 3.47.2.1 can be built on OpenIndiana Hipster March 2020

see https://forum.filezilla-project.org/viewtopic.php?f=2&t=52742

wxWiidgets also needs an uplift to v3.0.4 and built with GTK 3

#1

Updated by r a 5 months ago

Google Engineers have identified problems with GnuTLS and the fix was included in 3.6.14

See https://www.theregister.com/2020/06/10/gnutls_patches_security_hole/

So can GnuTLS be uplifted to 3.6.14

#2

Updated by Aurélien Larcher 5 months ago

GnuTLS is underway, for wxWidget pull requests are welcome if you really need it.

Also available in: Atom PDF