Project

General

Profile

Actions

Feature #12708

closed

Packages could be linted

Added by Andy Fiddaman about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
tools - gate/build tools
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

illumos-gate packages could be linted with `pkglint`.

A recent commit to gate introduced a new package which could not be installed on IPS distributions due to duplicated metadata.
It would be good to catch things like this earlier by running `pkglint` on the package set as part of the packaging checks.


Related issues

Related to illumos gate - Bug #12717: Stop ignoring pkgdepend errorsClosedAndy Fiddaman

Actions
Related to illumos gate - Bug #13667: pkg lint should not run if we are not building packagesClosedMatt Fiddaman

Actions
Actions #1

Updated by Rich Lowe about 2 years ago

  • Project changed from site to illumos gate
  • Category set to tools - gate/build tools
  • Target version deleted (1.1)
Actions #3

Updated by Andy Fiddaman about 2 years ago

  • Related to Bug #12717: Stop ignoring pkgdepend errors added
Actions #4

Updated by Andy Fiddaman about 2 years ago

Tested with many full RTI builds on OmniOS r151034 and latest OpenIndiana.

Built packages with and without this change and compared the manifests for all packages. In addition to the lines I explicitly added, driver/xvm/pv gained a new dependency on system/kernel/platform - this is because of the updated pkgdepend path for this component.

I introduced failures into manifests and confirmed that they broke the build and were properly picked up by either a failed `pkgdepend` run or by the final `pkglint`.

During testing I found a bug in the 'pkgdepend' command provided by IPS in
both OmniOS and OpenIndiana that occasionally (about 1 run in 20) caused packages to end up with
inconsistent variant information in them and then meant that they (rightly)
failed the pkglint introduced here.

The bug is now fixed in all supported OmniOS releases ('030, '032, '034) and
also in OpenIndiana - the fix is https://github.com/omniosorg/pkg5/commit/f0aceb9b3b918c3d92c6a8efe2d391b236c3e593

Actions #5

Updated by Electric Monk almost 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 069e6b7e31ba5dcbc5441b98af272714d9a5455c

commit  069e6b7e31ba5dcbc5441b98af272714d9a5455c
Author: Andy Fiddaman <omnios@citrus-it.co.uk>
Date:   2020-06-02T22:47:31.000Z

    12708 Packages could be linted
    12717 Stop ignoring pkgdepend errors
    Reviewed by: Rich Lowe <richlowe@richlowe.net>
    Reviewed by: John Levon <john.levon@joyent.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions #6

Updated by Matt Fiddaman about 1 year ago

  • Related to Bug #13667: pkg lint should not run if we are not building packages added
Actions

Also available in: Atom PDF