Project

General

Profile

Bug #12713

Network error after udating to 2020.04 / bge0: DL_BIND_REQ failed

Added by Sven Schmeling 2 months ago. Updated 11 days ago.

Status:
Duplicate
Priority:
Normal
Category:
driver - device drivers
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Hello,

after installing the latest updates (pkg update -rv / pkg image-update -v) the network of my HP xw4600 Workstation doesn't work anymore.

During the boot the following error occurs:

May 9 12:01:47 oiserver ip: [ID 210574 kern.error] bge0: DL_BIND_REQ failed: DL_SYSERR (errno 16)
May 9 12:01:47 oiserver ip: [ID 954675 kern.error] bge0: DL_UNBIND_REQ failed: DL_OUTSTATE

---
Before updating:

release:

             OpenIndiana Hipster 2019.10 (powered by illumos)
        OpenIndiana Project, part of The Illumos Foundation (C) 2010-2019
                        Use is subject to license terms.
                           Assembled 02 November 2019


dladm_show_phys:
LINK         MEDIA                STATE      SPEED  DUPLEX    DEVICE
bge0         Ethernet             up         1000   full      bge0


dladm_show_link:
bge0        phys      1500   up       --         --
buildvnic0  vnic      1500   up       --         bge0
dmzvnic0    vnic      1500   up       --         bge0
intravnic0  vnic      1500   up       --         bge0

dladm_show_vnic:

LINK         OVER         SPEED  MACADDRESS        MACADDRTYPE         VID
buildvnic0   bge0         1000   2:8:20:c8:e8:d7   random              0
dmzvnic0     bge0         1000   2:8:20:f6:95:5a   random              0
intravnic0   bge0         1000   2:8:20:75:7d:5c   random              0

zoneadm_list_ivc:

  ID NAME             STATUS     PATH                           BRAND    IP    
   0 global           running    /                              ipkg     shared
   1 oidmz            running    /datapool/zoneroots/oidmz      ipkg     excl  
   2 oiintra          running    /datapool/zoneroots/oiintra    ipkg     excl  
   - oibuild          installed  /datapool/zoneroots/oibuild    ipkg     excl 

message-file:

....
May  9 12:13:31 oiserver pcplusmp: [ID 805372 kern.info] pcplusmp: pciex14e4,167b (bge) instance 0 irq 0x11 vector 0x60 ioapic 0x1 intin 0x11 is bound to cpu 0
May  9 12:13:31 oiserver mac: [ID 469746 kern.info] NOTICE: bge0 registered
May  9 12:13:31 oiserver pcieb: [ID 586369 kern.info] PCIE-device: pci103c,1308@0, bge0
May  9 12:13:31 oiserver npe: [ID 236367 kern.info] PCI Express-device: pci103c,1308@0, bge0
May  9 12:13:31 oiserver genunix: [ID 936769 kern.info] bge0 is /pci@0,0/pci8086,294a@1c,5/pci103c,1308@0
May  9 12:13:32 oiserver bge: [ID 801725 kern.info] NOTICE: bge0: bge_check_copper: link now down speed 0 duplex 0
May  9 12:13:32 oiserver mac: [ID 469746 kern.info] NOTICE: vnic1000 registered
May  9 12:13:32 oiserver mac: [ID 469746 kern.info] NOTICE: vnic1001 registered
May  9 12:13:32 oiserver mac: [ID 435574 kern.info] NOTICE: vnic1000 link up, 0 Mbps, unknown duplex
May  9 12:13:32 oiserver mac: [ID 435574 kern.info] NOTICE: vnic1001 link up, 0 Mbps, unknown duplex
May  9 12:13:32 oiserver mac: [ID 469746 kern.info] NOTICE: vnic1002 registered
May  9 12:13:32 oiserver mac: [ID 435574 kern.info] NOTICE: vnic1002 link up, 0 Mbps, unknown duplex
May  9 12:13:32 oiserver pseudo: [ID 129642 kern.info] pseudo-device: devinfo0
May  9 12:13:32 oiserver genunix: [ID 936769 kern.info] devinfo0 is /pseudo/devinfo@0
May  9 12:13:34 oiserver genunix: [ID 241855 kern.info] This illumos instance has UUID 0fb8149a-1af2-4519-e86b-da25f379b912
May  9 12:13:35 oiserver bge: [ID 801725 kern.info] NOTICE: bge0: bge_check_copper: link now up speed 1000 duplex 2
May  9 12:13:35 oiserver mac: [ID 435574 kern.info] NOTICE: bge0 link up, 1000 Mbps, full duplex
May  9 12:13:35 oiserver genunix: [ID 454863 kern.info] dump on /dev/zvol/dsk/rpool/dump size 4088 MB

....

-------------
After updating:
release:

             OpenIndiana Hipster 2020.04 (powered by illumos)
        OpenIndiana Project, part of The Illumos Foundation (C) 2010-2020
                        Use is subject to license terms.
                           Assembled 03 May 2020

dladm_show_phys:

LINK         MEDIA                STATE      SPEED  DUPLEX    DEVICE
bge0         Ethernet             up         1000   full      bge0

dladm_show_link:

LINK        CLASS     MTU    STATE    BRIDGE     OVER
bge0        phys      1500   up       --         --
buildvnic0  vnic      1500   up       --         bge0


dladm_show_vnic:
LINK         OVER         SPEED  MACADDRESS        MACADDRTYPE         VID
buildvnic0   bge0         1000   2:8:20:c8:e8:d7   random              0

zoneadm_list_ivc:

  ID NAME             STATUS     PATH                           BRAND    IP    
   0 global           running    /                              ipkg     shared
   - oiintra          installed  /datapool/zoneroots/oiintra    ipkg     excl  
   - oidmz            installed  /datapool/zoneroots/oidmz      ipkg     excl  
   - oibuild          installed  /datapool/zoneroots/oibuild    ipkg     excl  


message-file:
....
May  9 10:47:18 oiserver pcplusmp: [ID 805372 kern.info] pcplusmp: pciex14e4,167b (bge) instance 0 irq 0x11 vector 0x60 ioapic 0x1 intin 0x11 is bound to cpu 0
May  9 10:47:19 oiserver mac: [ID 469746 kern.info] NOTICE: bge0 registered
May  9 10:47:19 oiserver pcieb: [ID 586369 kern.info] PCIE-device: pci103c,1308@0, bge0
May  9 10:47:19 oiserver npe: [ID 236367 kern.info] PCI Express-device: pci103c,1308@0, bge0
May  9 10:47:19 oiserver genunix: [ID 936769 kern.info] bge0 is /pci@0,0/pci8086,294a@1c,5/pci103c,1308@0
May  9 10:47:19 oiserver bge: [ID 801725 kern.info] NOTICE: bge0: bge_check_copper: link now down speed 0 duplex 0
May  9 10:47:19 oiserver mac: [ID 469746 kern.info] NOTICE: vnic1000 registered
May  9 10:47:20 oiserver ip: [ID 210574 kern.error] bge0: DL_BIND_REQ failed: DL_SYSERR (errno 16)
May  9 10:47:20 oiserver ip: [ID 954675 kern.error] bge0: DL_UNBIND_REQ failed: DL_OUTSTATE
May  9 10:47:20 oiserver pseudo: [ID 129642 kern.info] pseudo-device: devinfo0
May  9 10:47:20 oiserver genunix: [ID 936769 kern.info] devinfo0 is /pseudo/devinfo@0
May  9 10:47:20 oiserver genunix: [ID 241855 kern.info] This illumos instance has UUID eee2afd6-ad2c-4a4f-ac4f-ddad2f9072ca
May  9 10:47:21 oiserver genunix: [ID 454863 kern.info] dump on /dev/zvol/dsk/rpool/dump size 4088 MB
May  9 10:47:22 oiserver bge: [ID 801725 kern.info] NOTICE: bge0: bge_check_copper: link now up speed 1000 duplex 2
May  9 10:47:22 oiserver mac: [ID 435574 kern.info] NOTICE: bge0 link up, 1000 Mbps, full duplex
May  9 10:47:22 oiserver mac: [ID 435574 kern.info] NOTICE: vnic1000 link up, 1000 Mbps, unknown duplex

....

Any hints for what is wrong?


Files

bge_not_working.out.gz (8.24 KB) bge_not_working.out.gz Sven Schmeling, 2020-05-10 02:37 PM
bge_working.out.gz (2.99 MB) bge_working.out.gz Sven Schmeling, 2020-05-10 02:37 PM
bge_not_working_ipadm_enable_if.out1.gz (4.89 KB) bge_not_working_ipadm_enable_if.out1.gz Sven Schmeling, 2020-05-11 07:36 PM
bge_not_working_ipadm_enable_if.out2.gz (5.71 KB) bge_not_working_ipadm_enable_if.out2.gz Sven Schmeling, 2020-05-11 07:36 PM

Related issues

Related to illumos gate - Bug #12686: dladm: vnic creation over bge0 failed: object already existsClosed

Actions
Is duplicate of illumos gate - Bug #12686: dladm: vnic creation over bge0 failed: object already existsClosed

Actions

History

#1

Updated by Sven Schmeling 2 months ago

installed:

pci bus 0x003f cardnum 0x00 function 0x00: vendor 0x14e4 device 0x167b
 Broadcom Inc. and subsidiaries NetXtreme BCM5755 Gigabit Ethernet PCI Express
 CardVendor 0x103c card 0x1308 (Hewlett-Packard Company, Card unknown)
  STATUS    0x0010  COMMAND 0x0046
  CLASS     0x02 0x00 0x00  REVISION 0x02
  BIST      0x00  HEADER 0x00  LATENCY 0x00  CACHE 0x10
  BASE0     0x00000000f3000000 SIZE 65536  MEM64
  MAX_LAT   0x00  MIN_GNT 0x00  INT_PIN 0x01  INT_LINE 0x05

#3

Updated by Sven Schmeling 2 months ago

here are more infos:

After booting no network is working.

ipadm_show_if:

IFNAME     STATE    CURRENT      PERSISTENT
lo0        ok       -m-v------46 ---
bge0       disabled ------------ -46

ipadm_enable_if_t_bge0:

unix: WARNING: kstat create('unix', 0, 'bge0'): namespace collision
ipadm: Could not enable bge0 : Interface already in use
unix: WARNING: kstat create('bge0', 0, 'mac_misc_stat'): namespace collision
ip: bge0: DL_BIND_REQ failed: DL_SYSERR (errno 16)
ip: bge0: DL_UNBIND_REQ failed: DL_OUTSTATE

ipadm_disable_if_t_bge0:

ipadm: Could not disable bge0: Interface does not exist

#4

Updated by Sven Schmeling 2 months ago

similar to https://www.illumos.org/issues/12686:

Attaching the output of dtrace -n 'fbt:bge::{ trace(arg0); trace(arg1); }' -o /var/tmp/bge.out
It is the output from the running system. No special action was taken.

bge_work_out: System updated at 21. March 2020
bge_not_working: System updated at 08. May 2020

#5

Updated by Marcel Telka 2 months ago

  • Related to Bug #12686: dladm: vnic creation over bge0 failed: object already exists added
#6

Updated by Robert Mustacchi 2 months ago

Hi Sven, For the DTrace bits to be useful, it'd really help to run them while doing the ipadm enable if. That'll really help me tell if it's the same problem or not.

#7

Updated by Sven Schmeling 2 months ago

Hello Robert.

i startet the BE with the non working network.
Then i ran the dtrace - script followed by an "ipadm enable-if -t bge0" after a few seconds.
=> Output: bge_not_working_ipadm_enable_if.out1.gz

After stopping the dtrace-script i repeated the operation one time more.
=> Output: bge_not_working_ipadm_enable_if.out2.gz

Regards

#8

Updated by Robert Mustacchi 2 months ago

Hi Sven, thanks for providing that. Based on this, I can pretty clearly say that this is the same problem as in 12686. I've got a fix for that about ready to go back that we've verified. I'm going to mark this as a duplicate and this should all be fixed shortly. Thank you very much for the additional information and I'm sorry for the trouble that you had.

#9

Updated by Robert Mustacchi 2 months ago

  • Project changed from OpenIndiana Distribution to illumos gate
  • Category set to driver - device drivers
  • Status changed from New to Closed
  • Assignee set to Robert Mustacchi
#10

Updated by Robert Mustacchi 2 months ago

  • Is duplicate of Bug #12686: dladm: vnic creation over bge0 failed: object already exists added
#11

Updated by Joshua M. Clulow 11 days ago

  • Status changed from Closed to Duplicate

Also available in: Atom PDF