Project

General

Profile

Feature #12734

bhyve on AMD should report SVM as disabled

Added by Patrick Mooney 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cmd - userland programs
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
bhyve
Gerrit CR:

Description

Upstreaming OS-8008 from SmartOS:

As reported in https://github.com/joyent/smartos-live/issues/843 a Windows guest will hang at boot on AMD boxes without the "-w" command line flag (Ignore accesses to unimplemented Model Specific Registers).

Looking at this it seems Windows tries to read VM_CR MSR (C001_0114h).

rdmsr to register 0xc0010114 on vcpu 3

It seems that Windows ignores the cpuid bits here and attempts to poke the MSR anyways.

To test this change I ran a DEBUG platform with the change on our AMD Epyc lab box and confirmed I was able to boot a Windows bhyve instance without the "-w" flag. I also got confirmation that the user who reported the original issue was able to do the same on their hardware with the provided patched platform.


Related issues

Is duplicate of illumos gate - Feature #12665: want modern bhyveClosedPatrick Mooney

Actions
#1

Updated by Patrick Mooney 8 months ago

This was missed in the commit list for #12665 and has already been imported there.

#2

Updated by Patrick Mooney 8 months ago

  • Status changed from New to Closed
#3

Updated by Patrick Mooney 8 months ago

Also available in: Atom PDF