Project

General

Profile

Feature #12812

Vietnamese input method - Unikey

Added by jiaxing ruan 5 months ago. Updated 3 months ago.

Status:
New
Priority:
High
Assignee:
Category:
Internationalisation
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

I tried to create an account on sfe to add to their wishlist but this site has never send an activation email to me. I went to topicbox, but it seemed this is commercial. I'm not an developer so I don't know what to do. After a while I found this site, fortunately, I could register.

I'm just a normal user that wanted to use OpenIndiana on desktop alongside of Linux. This alternative OS has a working Firefox browser so it's totally possible to use as a daily OS. But I quickly found ibus on OI doesn't have the Unikey method. On Linux, it's usually provided by the package ibus-unikey. I tried with m17n and very soon I found this version of m17n is too old so it doesn't support Vietnamese!

Please consider updating ibus and the corresponding package and adding the Unikey input method. On Linux, I switched to fcitx and fcitx-unikey for a long time but ibus is the default on OI so I just go with ibus. I know how to install LibreOffice but without a Vietnamese input method it's useless for me! Thank you a lot.

#1

Updated by Aurélien Larcher 5 months ago

Hi,
thank you for your message :)
Is it this package that would be required?

https://github.com/vn-input/ibus-unikey

#2

Updated by giahung 1997tn 5 months ago

Aurélien Larcher wrote:

Hi,
thank you for your message :)
Is it this package that would be required?

https://github.com/vn-input/ibus-unikey

Yes. More information: ibus can't work with qt5 based apps. On Linux, I switched to fcitx completely but on OI we only have ibus so I just live with ibus. I only want to input Vietnamese on LibreOffice (GTK3) so I think ibus is enough for me :)

p/s: I'm the OP. I found my previous account name sounds too Chinese so I created this new one, definitely more Vietnamese :)

#3

Updated by gh origin 3 months ago

That's not something hard to do. Joyent already has ibus and ibus-unikey on their pkgsrc repo. Everything the developers need to do is pull it to their repo and build binary packages. But the only thing they are lacking is time!

Also available in: Atom PDF