Project

General

Profile

Actions

Bug #12828

closed

ucode/update.intel should be able to use git repos

Added by Dan McDonald over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
system data
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Instead of requiring $1 be a tarball, why not also include:

  • No arg > clone from well-known Intel git repo
  • Directory arg > skip tar step and pull right out of there.
  • File arg ==> As before, treat it like a tarball.

Tested using all three tactics, resulting #12816 changes match in each case.


Related issues

Related to illumos gate - Bug #12815: ucode/update.intel needs pkgfmt fixIn ProgressDan McDonald

Actions
Related to illumos gate - Feature #12816: Update Intel microcode to 20200616ClosedDan McDonald

Actions
Is duplicate of illumos gate - Bug #12817: ucode/update.intel should be able to use git reposIn Progress

Actions
Actions #1

Updated by Dan McDonald over 1 year ago

  • Related to Bug #12815: ucode/update.intel needs pkgfmt fix added
Actions #2

Updated by Dan McDonald over 1 year ago

Actions #3

Updated by Dan McDonald over 1 year ago

  • Subject changed from ucode/update.intel should be able to use git repo to ucode/update.intel should be able to use git repos
Actions #4

Updated by John Levon over 1 year ago

filed as #12817 ?

Actions #5

Updated by Dan McDonald over 1 year ago

John Levon wrote:

filed as #12817 ?

Damn, forgot about that. Will close as dup.

Actions #6

Updated by Dan McDonald over 1 year ago

  • Status changed from New to Duplicate

Closing as duplicate.

Actions #7

Updated by Dan McDonald over 1 year ago

  • Is duplicate of Bug #12817: ucode/update.intel should be able to use git repos added
Actions

Also available in: Atom PDF