Project

General

Profile

Actions

Bug #12842

closed

pcfs very poor performance

Added by giahung 1997tn over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

The Linux people going to have exFAT and our implementation of FAT32 is still bad :(

My external disk is an 128 GB SSD formatted with FAT32.

My OI installation is also on an 256 GB SSD.

When I insert the external disk, OI immediately mount it as pcfs and open it with Caja.

But what make me surprise most is the copying speed, it's about 5 MB/s! It would took days to complete copying my data. So I decided to use a vmdk to wrap my external disk and inserted it into a Linux VM on my VirtualBox. You know? It completed copying just after 2 minutes!

We really need to improve our pcfs implementation.


Related issues

Is duplicate of illumos gate - Bug #2092: terrible performance from PCFSNewJohn Sonnenschein2012-02-08

Actions
Actions #1

Updated by Dan McDonald over 1 year ago

Known problem (would love someone to fix this). Please close this as a duplicate of #2092 and followup there.

Actions #2

Updated by Marcel Telka over 1 year ago

  • Related to Bug #2092: terrible performance from PCFS added
Actions #3

Updated by giahung 1997tn over 1 year ago

Dan McDonald wrote:

Known problem (would love someone to fix this). Please close this as a duplicate of #2092 and followup there.

How to close it? I don't see any option.

Actions #4

Updated by Marcel Telka over 1 year ago

  • Status changed from New to Duplicate
Actions #5

Updated by Marcel Telka over 1 year ago

  • Is duplicate of Bug #2092: terrible performance from PCFS added
Actions #6

Updated by Marcel Telka over 1 year ago

  • Related to deleted (Bug #2092: terrible performance from PCFS)
Actions

Also available in: Atom PDF