Project

General

Profile

Actions

Bug #12848

closed

Clarify bhyve's dual license

Added by Michael Zeller almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
bhyve
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
bhyve
Gerrit CR:

Description

The illumos bhyve port originally began as a code drop from Pluribus, which they agreed would be released under the CDDL. Quite a bit of this code was from FreeBSD itself, bearing its own 2-clause BSD license. Throughout the continued porting and update process, Joyent chose to dual-license subsequent updates under both the CDDL and 2-clause BSD. Files which were pure additions (rather than those shared with FreeBSD bhyve) should be made to reflect that nature in their copyright attribution.


Related issues

Related to illumos gate - Bug #13000: bhyve sources should reflect license detailsClosedPatrick Mooney

Actions
Actions #1

Updated by Patrick Mooney almost 2 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Assignee set to Michael Zeller
  • Tags set to bhyve

Un-wrapped the description

Actions #2

Updated by Patrick Mooney almost 2 years ago

Andy F has confirmed that the OmniOS Community Edition Association accepts this dual-licensing for their changes to vmm_sol_dev.c.

Actions #3

Updated by Patrick Mooney almost 2 years ago

  • Subject changed from Clarify bhyve's dual license to Clarify bhyve's dual license
Actions #4

Updated by Patrick Mooney almost 2 years ago

Being a comments-only change, I ran this through a build to do wsdiff(1) and saw only the expected churn. There were text changes to the vmm module, but they were due to __LINE__ being incremented in asserts.

Actions #5

Updated by Electric Monk almost 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 1fa07ac719189ed3e8a0f8170264877c29bff62b

commit  1fa07ac719189ed3e8a0f8170264877c29bff62b
Author: Mike Zeller <mike@mikezeller.net>
Date:   2020-06-12T15:30:32.000Z

    12848 Clarify bhyve's dual license
    Reviewed by: Andy Fiddaman <omnios@citrus-it.co.uk>
    Reviewed by: Patrick Mooney <pmooney@oxide.computer>
    Reviewed by: Jorge Schrauwen <jorge@blackdot.be>
    Approved by: Robert Mustacchi <rm@fingolfin.org>

Actions #6

Updated by Patrick Mooney almost 2 years ago

  • Related to Bug #13000: bhyve sources should reflect license details added
Actions

Also available in: Atom PDF