Project

General

Profile

Actions

Bug #12850

closed

demangle(1) can trip up on names starting with underscore

Added by Jason King about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

I noticed that when piping certain output through demangle(1), names that start with '_' will generate an error. The issue is that it cannot determine which language generated the mangled symbol (since it's not actually one), which causes the sysdemangle function to error with ENOTSUP instead of EINVAL. The fix is trivial -- both EINVAL and ENOTSUP errors should just prompt demangle(1) to output the original string.

Actions #1

Updated by Jason King about 2 years ago

For testing, I ran a copy of demangle(1) with the change agains the original output that caused the error. The error no longer appears, and the output was now as expected.

Actions #2

Updated by Electric Monk about 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit b30f02def0d29c7f2398666939cf35cf81f809f1

commit  b30f02def0d29c7f2398666939cf35cf81f809f1
Author: Jason King <jason.king@joyent.com>
Date:   2020-06-12T22:28:37.000Z

    12850 demangle(1) can trip up on names starting with underscore
    Reviewed by: Andrew Stormont <andyjstormont@gmail.com>
    Reviewed by: Yuri Pankov <ypankov@tintri.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF