Project

General

Profile

Bug #12876

Qt5 package is incomplete

Added by giahung 1997tn 4 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

When I searched about qmake, the only thing I found is the qt5 package. So I installed it but I found qmake is not included. If you are only packaged the library part of qt5 then please also packaged the qmake tool in a separate package. Thanks.


Related issues

Related to OpenIndiana Distribution - Bug #12896: QT5 manifest needs mediated symlinksNew

Actions

History

#1

Updated by Aurélien Larcher 4 months ago

  • Status changed from New to Rejected

qmake is provided.

#2

Updated by Gary Mills 4 months ago

The package is: library/qt4

I found this by:

pkg search -o path,pkg.name -r /usr/bin/qmake
#3

Updated by giahung 1997tn 4 months ago

Aurélien Larcher wrote:

qmake is provided.

Which package? It's obviously not included in qt5 package or in a separate package.

It seemed you don't like me. You didn't invest anything but look at my name you just reject it altogether.

#4

Updated by giahung 1997tn 4 months ago

Gary Mills wrote:

The package is: library/qt4

I found this by:

[...]

This is of qt4. Please note that qmake-4 and qmake-5 (qt5's qmake) are different. They are provided by serparate package on Linux. This only confirmed that qmake-5 is not packaged.

#5

Updated by Aurélien Larcher 4 months ago

I packaged qt5 so I know it is there, I did not have to look :)

narval> pkg search -r -o path qmake
PATH
usr/lib/qt/4.8/bin/amd64/qmake
usr/lib/qt/4.8/bin/qmake
usr/lib/qt/5.8/bin/amd64/qmake
usr/lib/qt/5.8/bin/qmake
usr/lib/qt/5.8/bin/amd64/qmake
usr/lib/qt/5.8/bin/qmake
usr/bin/amd64/qmake
usr/bin/qmake

All consumers in oi-userland prepend the qt[4-5] prefix in the build recipes to avoid issues.
We cannot use a mediator since they are not compatible.
Symlinks qmake-4 and qmake-5 could be added but they would not bring much value.

#6

Updated by giahung 1997tn 4 months ago

Aurélien Larcher wrote:

I packaged qt5 so I know it is there, I did not have to look :)

narval> pkg search -r -o path qmake
PATH
usr/lib/qt/4.8/bin/amd64/qmake
usr/lib/qt/4.8/bin/qmake
usr/lib/qt/5.8/bin/amd64/qmake
usr/lib/qt/5.8/bin/qmake
usr/lib/qt/5.8/bin/amd64/qmake
usr/lib/qt/5.8/bin/qmake
usr/bin/amd64/qmake
usr/bin/qmake

All consumers in oi-userland prepend the qt[4-5] prefix in the build recipes to avoid issues.
We cannot use a mediator since they are not compatible.
Symlinks qmake-4 and qmake-5 could be added but they would not bring much value.

I could sure with you the there is no such thing as /usr/bin/qmake. This is the reason why I tried to run qmake, bash just said command not found. Please check your package. /usr/bin/qmake should be a symlink but it doesn't exist on my system. You put it in non standard path so I can't found it. I'm still pretty new to the Illumos world, so I don't know this pkg search syntax, I only know to search for package via pkg search -rp.

BTW, if you are already the maintainer of qt5 package, could you package qtcreator or at least featherpad, too? I tried to find a C++ IDE for OI but didn't found any. There is no CodeBlocks, no CodeLite, no Eclipse,... nothing. Eclipse stopped support for Solaris (both 10 and 11) for a while. There is Netbeans, but Oracle was not yet contribute the C++ part and as my previous issue said, the fonts looks ugly and the only way to fix is to patch openjdk. I could compile wxwidgets from source but failed to compile CodeBlocks. I also tried to build Otter Browser but failed since there is no qtwebkit on OI. Please note that QtWebKit is now no longer part of Qt but in this repo: https://github.com/qtwebkit/qtwebkit

If you already have qt5 why don't package qtcreator, too? Does qtcreator depend on QtWebEngine so you can't build it?

BTW, Pluma segmentation fault for me too much. Software on OI is too lacked and not well tested. Pluma has never failed me on Linux. Apart from Pluma, only Vim and Emacs left. And I don't want to use them. Featherpad is a nice Qt5 based text editor, it's very portable so it's even ported to HaikuOS. Please package it for OI. I will thank you very much.

#7

Updated by Aurélien Larcher 4 months ago

As we already discussed you need to use /usr/lib/qt/5.8/bin/qmake since /usr/bin/qmake is for Qt4.

Nobody here is paid to work on OI and therefore each user maintains what they need.
I have zero interest in Qt5 but I packaged it as a courtesy to help the community.
In the future I will probably spend again dozens of hours patching and packaging Qt5 for the rest of us without having any use of it ;) and get complains that it is not like Ubuntu where they can install stuff easily etc...

Spare time is not plenty enough to package and maintain things for all the users opening tickets on this tracker... and there are better things to do in life ;)
Linux distributions produced by Red Hat and Canonical have full time employees to do the job and make your life easy, and that's the trick: they are full time employees, it is their job to put out packages out so that users like us can beta test their distributions perpetually.

People here spend time to help the illumos community but this cannot be a commitment to provide support to any user that comes and has a request for a new package.

OpenIndiana is not for end user I am afraid because people may need to fix stuff themselves... and we cannot support extra packages if there is not commitment by users to contribute to the maintenance.

#8

Updated by Gary Mills 4 months ago

  • Related to Bug #12896: QT5 manifest needs mediated symlinks added

Also available in: Atom PDF