Project

General

Profile

Actions

Bug #12889

closed

ctfconvert fails on empty array

Added by Jason King about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
tools - gate/build tools
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

While porting some OpenZFS bits, ctfconvert fails with ctfconvert: failed to get unsigned attribute for type: DW_DLE_ATTR_FORM_BAD.

There are a number of instances of type foo[] = { }; in the ported code, which appear to be the cause:

root@pi:~# cat ctftest.c
int test[] = { };
root@pi:~# gcc -g -c ctftest.c
root@pi:~# ctfconvert ctftest.o
ctfconvert: failed to get unsigned attribute for type: DW_DLE_ATTR_FORM_BAD

Related issues

Is duplicate of illumos gate - Bug #10854: empty struct array confuses CTFClosed2019-04-25

Actions
Actions

Also available in: Atom PDF