Project

General

Profile

Actions

Bug #12957

closed

Some ipadm and dladm commands are slow on i40e

Added by Paul Winder almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Some of the network management commands when used against i40e interfaces are slow. Eg

create-aggr 37s
set-linkprop -p mtu aggr 10m
delete-aggr 20s
create-vnic 16s
create-if i40e 20s
delete-if i40e 10s

The majority of the time is caused by a misprogrammed delay used in ring teardown. The command is similar to:

/* delay 50ms */
delay(50 * drv_usectohz(1000))

This is supposed to delay by 50ms .... but if the tick is 100Hz (so not set to highres tick), this ends up being 500ms. And when there is this delay for every ring and there are 256 rings, that's 128s.


Related issues

Related to illumos gate - Bug #12958: i40e allocates large amounts of DMAClosed

Actions
Related to illumos gate - Bug #12972: Remove reference to deprecated ddi_power from i40eClosedPaul Winder

Actions
Actions

Also available in: Atom PDF