Project

General

Profile

Actions

Bug #12997

closed

clean up stale vdev driver in bhyve

Added by Patrick Mooney 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
bhyve
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
bhyve
Gerrit CR:

Description

When bhyve was imported from the Pluribus wad, it included a "vdev" driver in uts/i86pc/io/vmm/io. This has long since been removed upstream (https://github.com/freebsd/freebsd/commit/94bdd999bb990eb9d14b55fa8a90bfd8e4005a8e) and is not referenced from any of our existing bhyve code. It should be removed in our copy like it was upstream.

Actions #1

Updated by Electric Monk 9 months ago

  • Gerrit CR set to 820
Actions #2

Updated by Patrick Mooney 9 months ago

As noted, this code is not reference by anything else in bhyve, and has been effectively dead since the FreeBSD 11 resync of illumos bhyve. I booted up a test BE with this change and confirmed that bhyve operation was unchanged (which, as expected, was the case).

Actions #3

Updated by Electric Monk 9 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 84b52440bb17285d25cdba822f4ed46754e76f37

commit  84b52440bb17285d25cdba822f4ed46754e76f37
Author: Patrick Mooney <pmooney@pfmooney.com>
Date:   2020-07-29T18:50:07.000Z

    12997 clean up stale vdev driver in bhyve
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Approved by: Robert Mustacchi <rm@fingolfin.org>

Actions

Also available in: Atom PDF