Project

General

Profile

Bug #13053

Very serious graphic stack bug

Added by gh origin 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Urgent
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Sorry if it's a duplication of bug 13052. I don't know the Graphics/DRM is a separate project from the OpenIndiana distribution. Please pardon my ignorant.

I think Graphics/DRM is the better place to report this bug:

gh origin wrote:

The bug 12964 I have reported has not yet resolved (just try with a newly installed OI system, upgrade still broke intel graphics). In fact, nothing was done to resolve it.

I used the freeze feature of pkg to freeze the xorg intel video package so pkg will not upgrade it. It worked. The package was kept. But the bug still happen. My system still crashes.

So the problem must be on something deeply rooted inside update packages. It needs real efforts debugging and should be considered as a serious bug prevent the release of OI 20.10 from happening if it's not yet resolved.

Intel graphics is the most popular graphics system used by OI desktop users. We as OI desktop users need the graphics to work. Developers, please try your best to resolve it to keep OI as a desktop system relevance.

Thank you very much.


Files

update.txt (41.1 KB) update.txt gh origin, 2020-08-18 03:25 PM

Related issues

Related to OpenIndiana Distribution - Bug #13052: Very serious graphic stack bugResolvedAlexander Pyhalov

Actions
Related to OpenIndiana Distribution - Bug #12964: Continuously reboot after installing the latest updateResolved

Actions
Related to Graphics/DRM - Feature #12395: Update to libdrm >= 2.4.97NewAurélien Larcher

Actions
#1

Updated by gh origin 2 months ago

  • Related to Bug #13052: Very serious graphic stack bug added
#2

Updated by gh origin 2 months ago

  • Related to Bug #12964: Continuously reboot after installing the latest update added
#3

Updated by Alexander Pyhalov 2 months ago

Hi.
Can you share the stack trace or kernel dump file?

#4

Updated by gh origin 2 months ago

#5

Updated by gh origin 2 months ago

Alexander Pyhalov wrote:

Hi.
Can you share the stack trace or kernel dump file?

Here you are: https://filebin.net/y2x0ryge79eikbdt

#6

Updated by Alexander Pyhalov 2 months ago

Stack trace:

> $C
fffffe003fc76830 mutex_enter+0xb()
fffffe003fc76900 devmap_device+0x62(fffffe2cfb7a3cd0, 0, fffffe003fc76a78, 1c000, 1000, 1)
fffffe003fc769d0 devmap_setup+0x229(5d00000000, 1c000, 0, fffffe003fc76a78, 1000, f, ffffffff0000000f, fffffe2c00000001, fffffe2cf3fe5258)
fffffe003fc76a30 ddi_devmap_segmap+0x2b(5d00000000, 1c000, 0, fffffe003fc76a78, 1000, f, ffffffff0000000f, 1, fffffe2cf3fe5258)
fffffe003fc76ae0 i915_gem_mmap_ioctl+0xde(5d00000000, fffffe2ce7dc6380, fffffe003fc76b38, fffffe2cece71240, 202083, fffffe2cf3fe5258)
fffffe003fc76c20 drm_ioctl+0x164(5d00000000, fffffe2cece71240, c028645e, fffffc7fffdff8c0, 202083, fffffe2cf3fe5258)
fffffe003fc76cc0 drm_sun_ioctl+0xef(5d00000000, c028645e, fffffc7fffdff8c0, 202083, fffffe2cf3fe5258, fffffe003fc76e18)
fffffe003fc76d00 cdev_ioctl+0x2b(5d00000000, c028645e, fffffc7fffdff8c0, 202083, fffffe2cf3fe5258, fffffe003fc76e18)
fffffe003fc76d50 spec_ioctl+0x45(fffffe2cf9539400, c028645e, fffffc7fffdff8c0, 202083, fffffe2cf3fe5258, fffffe003fc76e18, 0)
fffffe003fc76de0 fop_ioctl+0x5b(fffffe2cf9539400, c028645e, fffffc7fffdff8c0, 202083, fffffe2cf3fe5258, fffffe003fc76e18, 0)
fffffe003fc76f00 ioctl+0x153(b, c028645e, fffffc7fffdff8c0)
fffffe003fc76f10 sys_syscall+0x17d()
#7

Updated by gh origin 2 months ago

Alexander Pyhalov wrote:

Stack trace:

[...]

Not very different from the stack trace of it on bug 12964.
The attachment is the whole output of pkg update -nv so you could look into and find something potentially caused this.

I found other from the userspace libdrm, there also is an update to the drm driver. Could it is the real cause of all of this?

Recalled from my vague memory, I think I saw on the console when it crashed something like error dereference of null pointer. I hope it could help you diagnose the problem and also hope you could do it soon. I have to wipe my current OI installation to go back to Linux in order to work so I will absent from this mailing lists and can't reply to you anymore.

Bye.

#8

Updated by Alexander Pyhalov 2 months ago

  • Status changed from New to Resolved

Rebuilding gfx-drm should have fixed the issue.

#9

Updated by gh origin 2 months ago

Alexander Pyhalov wrote:

Rebuilding gfx-drm should have fixed the issue.

Confirmed. The issue is gone with the latest update.

Also available in: Atom PDF