Project

General

Profile

Bug #13077

bhyve kernel should be -Wformat clean

Added by Patrick Mooney 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
bhyve
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
bhyve
Gerrit CR:

Description

When bhyve was ported to illumos, the printf-like warnings in the kernel were suppressed with -Wno-format. As we're doing other clean up there, it would be nice to remove that warning gag and fix any problems which arise.

#1

Updated by Electric Monk 6 months ago

  • Gerrit CR set to 871
#2

Updated by Patrick Mooney 6 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100
#3

Updated by Patrick Mooney 6 months ago

Given the nature of the change, testing was performed with wsdiff(1). It confirmed that the only changes to the bhyve text were line offsets moving about due to dead code removal. I also smoke-tested it to make sure that booting a guest was still fine, just as a precaution. (It passed that as well, as expected)

#4

Updated by Electric Monk 6 months ago

  • Status changed from In Progress to Closed

git commit 9dc804b9db4598936de071708cbc40525f06eb5d

commit  9dc804b9db4598936de071708cbc40525f06eb5d
Author: Patrick Mooney <pmooney@pfmooney.com>
Date:   2020-09-09T19:50:22.000Z

    13077 bhyve kernel should be -Wformat clean
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Approved by: Robert Mustacchi <rm@fingolfin.org>

Also available in: Atom PDF