Project

General

Profile

Actions

Feature #13079

closed

Add ksensor support for voltage and current sensors

Added by Robert Mustacchi 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

When the ksensor framework was introduced, it as designed such that we could add sensors for other types of peripherals. I've found a couple of devices that expose additional sensors such as current and voltage ranging from the AMD CPUs to the Chelsio parts. It'd be nice if we could add these to the framework.

As part of this, I've renamed the temperature sensor to be a scalar, to represent the core type of sensor that this is (a single discrete value) and fixed a few other minor inconsistencies in what we have. While I don't think it makes sense to commit to this yet, after this we can probably write some manual pages to describe the current, evolving interfaces.

Actions #1

Updated by Electric Monk 11 months ago

  • Gerrit CR set to 874
Actions #2

Updated by Robert Mustacchi 11 months ago

I tested this in a couple different ways:

  • I used the ksensor os-tests and verified that they old passed, which were updated to include current and voltage sensors.
  • I checked a couple of existing driver that were updated because of this, in particular the igb and amdf17nbdf changes.
  • I had the testing that went on through #13080 and #13081 which helped verify the fmtopo paths for the new sensors.
Actions #3

Updated by Electric Monk 11 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 1045e13a248d94941f864998aa859970ae3a4154

commit  1045e13a248d94941f864998aa859970ae3a4154
Author: Robert Mustacchi <rm@fingolfin.org>
Date:   2020-09-14T15:27:28.000Z

    13079 Add ksensor support for voltage and current sensors
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Reviewed by: Paul Winder <paul@winder.uk.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF