Project

General

Profile

Bug #1310

oi-build pkglint broken with pkg 0.166 on oi_151 due to linked images

Added by Alasdair Lumsden over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2011-07-31
Due date:
% Done:

100%

Estimated time:
Difficulty:
Hard
Tags:
needs-triage

Description

Unfortunately pkglint from pkg 0.166 is broken when used on non-linked images:

alasdair wget (alasdair2.uk): gmake publish
VALIDATING MANIFEST CONTENT: /export/home/alasdair/oi-build/components/wget/build/manifest-i386-wget.depend.res
/usr/bin/env PYTHONPATH=/export/home/alasdair/oi-build/tools/python PROTO_PATH="/export/home/alasdair/oi-build/components/wget/build/prototype/i386/mangled /export/home/alasdair/oi-build/components/wget/build/prototype/i386 /export/home/alasdair/oi-build/components/wget/build /export/home/alasdair/oi-build/components/wget wget-1.12"\
                /usr/bin/pkglint -c /export/home/alasdair/oi-build/i386/pkglint-cache \
                        -f /export/home/alasdair/oi-build/tools/pkglintrc /export/home/alasdair/oi-build/components/wget/build/manifest-i386-wget.depend.res
Lint engine setup...
Error: Unable to access any pkglint images under /export/home/alasdair/oi-build/i386/pkglint-cache
gmake: *** [/export/home/alasdair/oi-build/components/wget/build/.linted-i386] Error 1

I've narrowed this down with truss to being due to linked images:

open64("/repos/i386/pkglint-cache/ref_image/.org.opensolaris,pkg/linked/linked_prop.8408", O_RDONLY) Err#2 ENOENT
open64("/", O_RDONLY)                           = 3
getpid()                                        = 8408 [8407]
readlink("/proc/8408/path/3", "/", 1024)        = 1
close(3)                                        = 0
open64("/repos/i386/pkglint-cache/ref_image/.org.opensolaris,pkg/linked/linked_prop", O_RDONLY) Err#2 ENOENT
stat64("/repos/i386/pkglint-cache/ref_image/.org.opensolaris,pkg/state/avoid_set", 0x08045FE0) Err#2 ENOENT
umask(022)                                      = 022
chdir("/export/home/alasdair/oi-build/components/wget") = 0
getpid()                                        = 8408 [8407]
Error: Unable to access any pkglint images under /export/home/alasdair/oi-build/i386/pkglint-cache
write(1, " E r r o r :   U n a b l".., 99)      = 9

I'd propose we comment out CANONICAL_REPO in shared-macros.mk until this can be resolved properly.

History

#1

Updated by Alasdair Lumsden over 8 years ago

  • Status changed from New to In Progress

A workaround has been committed in changeset:

http://hg.openindiana.org/oi-build/rev/5249c17e80b2

Ultimately the root cause needs to be addressed - if we are to use the new pkg bits we need to implement linked images.

#2

Updated by Ken Mays over 5 years ago

  • Status changed from In Progress to Closed
  • Assignee changed from Alasdair Lumsden to Jon Tibble
  • % Done changed from 0 to 100

Also available in: Atom PDF