Project

General

Profile

Actions

Bug #13277

closed

installer crash: "unorderable types: int() <= NoneType()"

Added by jonathan sailor over 3 years ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Category:
Caiman (Installer)
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Hardware is a VM created with `virt-install --connect qemu:///system --name=indiana1 --memory=1024 --cpu=host --vcpus=2 --disk size=30 --cdrom OI-hipster-minimal-20200504.iso --nographics --rng /dev/urandom --console=pty` on a reasonably stock ubuntu 20.04 host.

Go through the install menus, selecting

1. Intro screen: escape-2
2. Disk screen: escape-2 (select 30GB ATA disk c1d0)
3. Installing onto a GPT labeled disk will cause the loss of all existing data" screen: right-arrow, enter
4. fdisk screen: escape-2 (default selected option is "Use the whole disk (EFI)")
5. network screen: down-arrow to switch focus from hostname field (leaving default hostname "openindiana") to select "Automatically", then escape-2
6. Timezone: downarrow/uparrow to select "Americas" then escape-2. Repeat for US, and Eastern
7. Date screen: escape-2 (default date is 2020-11-03 13:12, which is more or less accurate)
8. Username screen: enter "xxxxxx" in root PW field, downarrow. enter "xxxxxx" in confirm field, downarrow. Enter "jon" in real name, downarrow. Enter "jon" in username, downarrow. Enter "xxxxxx" in user password, downarrow. Enter "xxxxxx" in confirm field, press escape
9. Crash

The crash message printed is

```
An unhandled exception occurred.
TypeError: "unorderable types: int() <= NoneType()"
Full traceback data is in the installation log
Please file a bug at http://bugs.openindiana.org
Exiting Text Installer. Log is available at:
/tmp/install_log
```

the tail end of the traceback is

```
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/edit_field.py", line 249, in edit_loop
input_key = self.handle_input(self.getch())
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/edit_field.py", line 210, in handle_input
input_key = self.translate_input(input_key)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/inner_window.py", line 507, in translate_input
if curses.ascii.isdigit(input_key):
File "/usr/lib/python3.5/curses/ascii.py", line 59, in isdigit
def isdigit(c): return 48 <= _ctoi(c) <= 57
TypeError: unorderable types: int() <= NoneType()
```

and I'm attaching the full `/tmp/install_log` (renamed to `install_log.txt` to appease modern browsers).

For the "escape-2", I've tried: pressing escape quickly followed by 2; pressing escape, waiting a couple seconds, then pressing 2 (which is how I noticed the crash is on the escape); and using meta-2.


Files

install_log.txt (2.49 KB) install_log.txt jonathan sailor, 2020-11-03 06:16 PM

Related issues

Related to OpenIndiana Distribution - Bug #13446: OI install crashes unpon completion of root password/add new user phaseDuplicateChris Hutchinson

Actions
Is duplicate of OpenIndiana Distribution - Bug #15248: text-install fails when manually add network & add user (TypeError: '<=' not supported between instances of 'int' and 'NoneType')In Progress

Actions
Actions #1

Updated by jonathan sailor over 3 years ago

I just noticed if I up-arrow back to the username field, it doesn't crash. So possibly it's specific to password fields?

Actions #2

Updated by Marcel Telka 3 months ago

  • Target version changed from 2020.10 to Hipster
Actions #3

Updated by Marcel Telka 3 months ago

  • Related to Bug #13446: OI install crashes unpon completion of root password/add new user phase added
Actions #4

Updated by Marcel Telka 3 months ago

  • Category set to Caiman (Installer)
  • Status changed from New to Feedback
  • Assignee set to jonathan sailor

Is it possible to reproduce this with 2023.10 install media?

Actions #5

Updated by Marcel Telka 3 months ago

  • Related to Bug #15248: text-install fails when manually add network & add user (TypeError: '<=' not supported between instances of 'int' and 'NoneType') added
Actions #6

Updated by Marcel Telka 2 months ago

  • Related to deleted (Bug #15248: text-install fails when manually add network & add user (TypeError: '<=' not supported between instances of 'int' and 'NoneType'))
Actions #7

Updated by Marcel Telka 2 months ago

  • Is duplicate of Bug #15248: text-install fails when manually add network & add user (TypeError: '<=' not supported between instances of 'int' and 'NoneType') added
Actions #8

Updated by Marcel Telka 2 months ago

  • Status changed from Feedback to Duplicate

Closing as duplicate of #15248.

Actions

Also available in: Atom PDF