Project

General

Profile

Bug #13300

mlxcx_cq_setup() doesn't take required locks for ASSERTs

Added by Robert Mustacchi 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
driver - device drivers
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

On debug, a user saw a panic occur in mlxcx_arm_cq() because they didn't have the mlcq_arm_mtx lock held. This only really blows up on debug builds. The reason that this happens and isn't so bad is that the setup code path didn't grab the muetx that was added for this purpose. However, all the code paths that matter once the device is up, are doing so.

I put together a patch and they confirmed that it fixed the problem that they had.

Also available in: Atom PDF