Project

General

Profile

Bug #13321

Package conflict between openindiana.org and localhostoih

Added by Hubert Garavel 11 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

A package conflict recently appeared (November 2020?) between the OpenIndiana repository
and the TeX/LaTeX installation provided by localhostoih.

# pkg update

Creating Plan (Checking for conflicting actions): -
pkg update: The following packages all deliver file actions to usr/include/synctex/synctex_parser.h:

  pkg://localhostoih/text/texlive@2018,5.11-0.2017.0.0.5:20190113T154908Z
  pkg://openindiana.org/library/libsynctex@2.0.0,5.11-2020.0.1.0:20200912T190051Z

These packages cannot be installed together. Any non-conflicting subset
of the above packages can be installed.

The following packages all deliver file actions to usr/include/synctex/synctex_parser_utils.h:

  pkg://openindiana.org/library/libsynctex@2.0.0,5.11-2020.0.1.0:20200912T190051Z
  pkg://localhostoih/text/texlive@2018,5.11-0.2017.0.0.5:20190113T154908Z

These packages cannot be installed together. Any non-conflicting subset
of the above packages can be installed.

A workaround is

# pkg update --reject pkg://openindiana.org/library/libsynctex

but this is not very satisfactory. I wonder why OpenIndiana wants to provide
SyncTeX although it does not provide TeX. By the way, having an up-to-date
installation of LaTeX is a must for the dissemination of OpenIndiana in academia.

No data to display

Also available in: Atom PDF