Project

General

Profile

Actions

Bug #13370

closed

mlxcx_intr_n doing redundant check on mleqe_event_type

Added by Alex Wilson 10 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

mlxcx_intr_n is currently doing a check on mleqe_event_type even though it already has an ASSERT3U() covering the same check. This case should only ever be hit in the presence of a driver or firmware bug (and not a bug type that we've ever seen from the devices so far), so I think we should just demote the whole check to just the ASSERT3U(). That will reduce code size here and branching in the main data path interrupt handler.
Actions #1

Updated by Electric Monk 7 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 80d1a7bde98a8ab2881940a6fe6775073564f253

commit  80d1a7bde98a8ab2881940a6fe6775073564f253
Author: Alex Wilson <alex@cooperi.net>
Date:   2021-04-06T15:38:25.000Z

    13359 mlxcx_update_link_state can race against mlxcx_register_mac
    13370 mlxcx_intr_n doing redundant check on mleqe_event_type
    Reviewed by: Robert Mustacchi <rm@fingolfin.org>
    Reviewed by: Andy Fiddaman <andy@omnios.org>
    Reviewed by: Paul Winder <paul@winder.uk.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF