Project

General

Profile

Actions

Bug #13446

closed

OI install crashes unpon completion of root password/add new user phase

Added by Chris Hutchinson about 3 years ago. Updated 8 days ago.

Status:
Duplicate
Priority:
Normal
Category:
Caiman (Installer)
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

OI install will return to the Install OI menu after completing the root password/
create new user step, and pressing F2/ESC-2.
The problem as it turns out. Is that if the cursor is in ANY password field. OI
install will crash when F2/ESC-2 is pressed, to continue. The solution is simply
to move the cursor into any other field except a password field. Then press
F2/ESC-2. Where the install will continue as intended.


Related issues

Related to OpenIndiana Distribution - Bug #13277: installer crash: "unorderable types: int() <= NoneType()" Duplicatejonathan sailor

Actions
Is duplicate of OpenIndiana Distribution - Bug #15248: text-install fails when manually add network & add user (TypeError: '<=' not supported between instances of 'int' and 'NoneType')In Progress

Actions
Actions #1

Updated by Nona Hansel about 3 years ago

I tried several times to replicate this behaviour with current text install DVD image but I couldn't - every time it worked fine even with cursor in password field.

Actions #2

Updated by Chris Hutchinson about 3 years ago

Nona Hansel wrote in #note-1:

I tried several times to replicate this behaviour with current text install DVD image but I couldn't - every time it worked fine even with cursor in password field.

That's odd. I only discovered that moving the cursor out of the password fields worked. Because I mentioned my problem on the mailing lists, and someone told me that the installer crashed that way. They told me to move the cursor out of the password field before using F2/ESC-2, and it worked. :-)

Actions #3

Updated by Stephan Althaus about 3 years ago

I tried some installations on Jan,25 with the USB image OI-hipster-minimal-20201031.usb.
I left the cursor in the last password field, the installation went on normally.

i remembered this bug report after hitting the button to proceed but no issues here - gladfully.

Actions #4

Updated by John Groenveld almost 3 years ago

An unhandled exception occurred.
TypeError: "unorderable types: int() <= NoneType()"
Full traceback data is in the installation log
Please file a bug at http://bugs.openindiana.org
Exiting Text Installer. Log is available at:
/tmp/install_log
Welcome to the OpenIndiana illumos-06524cf4e4 installation menu

1  Install OpenIndiana
2 Install Additional Drivers
3 Shell
4 Terminal type (currently sun-color)
5 Reboot

Please enter a number [1]:

cat install_log
2021-03-03 21:43:26,569 - INFO : text-install:120 START
2021-03-03 21:44:17,600 - ERROR : fdisk_partitions.py:129 No partitions were selected. Continuing.
2021-03-03 21:44:28,164 - INFO : network_type.py:174 Configuring NIC as: none
2021-03-03 21:44:46,722 - ERROR : text-install:254 Install Profile:
Disk Info (c4t0d0):
Size: 8.0gb
BE name: openindiana
Overwrite boot configuration: True
NIC None:
Type: none
System Info:
Hostname: openindiana
TZ: UTC - UTC - UTC
Time Offset: -1 day, 23:59:25.921201
Keyboard: None
Locale: None
User Info(root):
Real name: None
Login name: root
Is Role: True
User Info(None):
Real name: None
Login name: None
Is Role: False
None
2021-03-03 21:44:46,734 - ERROR : text-install:255 Traceback (most recent call last):
File "/usr/bin/text-install", line 236, in <module>
SCREEN = SCREEN.show(INSTALL_PROFILE)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/base_screen.py", line 126, in show
return self.validate_loop()
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/base_screen.py", line 150, in validate_loop
next_screen = self.main_win.process_input(self)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/main_window.py", line 229, in process_input
input_key = self.central_area.process(input_key)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/inner_window.py", line 472, in process
input_key = self.objects[self.active_object].process(input_key)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/inner_window.py", line 472, in process
input_key = self.objects[self.active_object].process(input_key)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/edit_field.py", line 283, in process
self.edit_loop()
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/edit_field.py", line 249, in edit_loop
input_key = self.handle_input(self.getch())
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/edit_field.py", line 210, in handle_input
input_key = self.translate_input(input_key)
File "/usr/lib/python3.5/vendor-packages/osol_install/text_install/inner_window.py", line 507, in translate_input
if curses.ascii.isdigit(input_key):
File "/usr/lib/python3.5/curses/ascii.py", line 59, in isdigit
def isdigit(c): return 48 <= _ctoi(c) <= 57
TypeError: unorderable types: int() <= NoneType()

2021-03-03 21:44:46,737 - INFO : text-install:99 END

Actions #5

Updated by Matthew Fuller over 2 years ago

This also happens to me, installing 2021.04 in bhyve on FreeBSD using vm-bhyve, with terminal type set to xterm. Shifting out of the password fields also serves as a workaround.

Actions #6

Updated by Marcel Telka about 1 month ago

  • Target version changed from 2020.10 to Hipster
Actions #7

Updated by Marcel Telka about 1 month ago

  • Priority changed from High to Normal
Actions #8

Updated by Marcel Telka about 1 month ago

  • Status changed from New to Feedback
  • Assignee changed from OI Caiman to Chris Hutchinson

What install image was used for the installation?

Actions #9

Updated by Marcel Telka about 1 month ago

  • Related to Bug #13277: installer crash: "unorderable types: int() <= NoneType()" added
Actions #10

Updated by Marcel Telka about 1 month ago

This is possibly a duplicate of #13277.

Is it possible to reproduce with 2023.10 install media?

Actions #11

Updated by Marcel Telka 8 days ago

  • Is duplicate of Bug #15248: text-install fails when manually add network & add user (TypeError: '<=' not supported between instances of 'int' and 'NoneType') added
Actions #12

Updated by Marcel Telka 8 days ago

  • Status changed from Feedback to Duplicate

Closing as duplicate of #15248.

Actions

Also available in: Atom PDF