Project

General

Profile

Actions

Bug #13699

closed

strtod(3c)/wcstod(3c) man pages should mention math.h

Added by Marcel Telka 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
manpage - manual pages
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

In both strtod(3c) and wcstod(3c) man pages there is this wording:

       If the correct value is outside the range of representable values,
       ±HUGE_VAL, ±HUGE_VALF, or ±HUGE_VALL is returned (according to the sign
       of the value), a floating point overflow exception is raised, and errno
       is set to ERANGE.

The problem is that those constants (HUGE_VAL, HUGE_VALF, and HUGE_VALL) are not readily available when there is just stdlib.h or wchar.h included respectively (as suggested by the man pages synopsis) because they are defined in math.h, but math.h is not mentioned anywhere in either man page. We should change that.

Actions #1

Updated by Electric Monk 6 months ago

  • Gerrit CR set to 1403
Actions #3

Updated by Marcel Telka 6 months ago

Testing

I reviewed the manpages using the following commands:

MANPATH=usr/src/man man strtod
MANPATH=usr/src/man man wcstod

Nightly passed.

Actions #4

Updated by Marcel Telka 6 months ago

  • Status changed from In Progress to Pending RTI
Actions #5

Updated by Electric Monk 6 months ago

  • Status changed from Pending RTI to Closed
  • % Done changed from 0 to 100

git commit fc14a9f656c392f9e8344484089464f018de6ef6

commit  fc14a9f656c392f9e8344484089464f018de6ef6
Author: Marcel Telka <marcel@telka.sk>
Date:   2021-04-22T18:03:46.000Z

    13699 strtod(3c)/wcstod(3c) man pages should mention math.h
    Reviewed by: Robert Mustacchi <rm+illumos@fingolfin.org>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF