Project

General

Profile

Actions

Bug #13703

open

Hipster 2021.04 RC1 testing

Added by Reginald Beardsley 7 months ago. Updated 7 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Text installer will not install into a freshly created pool. It displays the install progress screen, but nothing happens after that.

I invoked /usr/bin/text-install using truss. Truss output is attached. Command was "truss -f -o truss.ouput-3".

Screen shot shows that size of truss file has not changed for 5 minutes. F9_Quit does not work. The only option is to kill the terminal.


Files

prtvtoc.png (87.3 KB) prtvtoc.png Reginald Beardsley, 2021-04-06 08:03 PM
pool.png (92.1 KB) pool.png Reginald Beardsley, 2021-04-06 08:03 PM
truss.png (100 KB) truss.png Reginald Beardsley, 2021-04-06 08:05 PM
install.truss-3 (1.61 MB) install.truss-3 Reginald Beardsley, 2021-04-06 08:06 PM
IMG_1772.JPG (939 KB) IMG_1772.JPG Reginald Beardsley, 2021-04-06 09:51 PM
IMG_1773.JPG (900 KB) IMG_1773.JPG Reginald Beardsley, 2021-04-06 10:11 PM
Actions #1

Updated by Reginald Beardsley 7 months ago

This disk was faulted out by a Solaris 10 u8 system and had two pools, a 100 GB mirrored root pool and a 1.8 TB RAIDZ1 export pool. A subsequent disk scan reported that the disk was OK. "zpool labelclear -f c4d0s1" appears to have resolved the issue.

As I only wanted to install to a freshly created pool in the s0 slice, I don't think that the existence of a corrupted pool label in the s1 slice should affect the installation process.

Install appeared to complete normally.

Actions #2

Updated by Reginald Beardsley 7 months ago

The BIOS IDE boot install booted normally. But it was unable to boot after changing the BIOS to AHCI mode.

A reinstall with the BIOS already in AHCI mode booted the ISO properly and appeared to complete, but would not boot from disk with the same error message.

It would be nice if the first case worked, but not essential. The 2nd case where the user has installed with the BIOS in AHCI mode should boot properly after installing.

I'll take a look at the text-installer script to see if I can sort out a proper way to allow the user to install onto a disk with multiple slices and an existing pool more gracefully.

Changing to the nVidia driver did not go well. See screen photo.

Actions #3

Updated by Reginald Beardsley 7 months ago

NB: system is an HP Z400 w/ BIOS version 3.61 and a Quadro FX 1800 graphics card.

As I've been at this for almost 4 hours I'm going to stop for now. More tomorrow.

Actions

Also available in: Atom PDF