Project

General

Profile

Actions

Bug #13737

open

Boot sequence hangs on Rocket Lake 11700K.

Added by Jeremy Andrews 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

I know, I know... even Linux barely supports this CPU yet and this is way too soon, but I figure I might as well report the issue here now for later. The motherboard is an MSI Z590A-PRO. I'm using OpenIndiana 2020.10, but I think this is probably an illumos issue given how early in the install process this is happening (apologies if I'm wrong).

I've tried with both the UHD 750 integrated graphics and an old GTX 560 Ti I have laying around. I also tried enabling CSM/Legacy mode in the BIOS while I had the video card inserted, but it defaulted to the EFI loader anyway, so I didn't get to test whether this would work in BIOS mode.

The first thing I see is a Time of Day error saying that the system clock jumped by 0x6 or 0x7. It seems to continue on from this, though.

If I enable verbose output, I can see that it's finding all the devices and naming them. It even recognizes the onboard audio. But at some point it hits this block device, and the sequence sits for a long time. After a long enough amount of time, it will finish and say "Done mounting live image," and then sit there forever. It never actually seems to completely hang, hitting Enter will still advance the screen by a line. There's just no further output and it seems stuck in some kind of loop.

I'm not terribly surprised that this didn't work, but I figured it wouldn't hurt to report the bug anyway.


Files

crop.jpg (1.93 MB) crop.jpg Screenshot of boot sequence Jeremy Andrews, 2021-04-20 07:22 PM
Actions #1

Updated by Jeremy Andrews 2 months ago

Well, it looks like everything is fine and I just stumbled over a few details. I misunderstood my BIOS and didn't realize it had separate options for booting a device from UEFI and just booting normally whenever CSM is turned on. So I actually did manage to get this booted and installed in BIOS/CSM mode, with a 560 Ti inserted, and ACPI disabled. It's complaining that it doesn't recognize the I225-V ethernet card, and said something about only 8 CPUs being enabled. Still, I can probably find a PCI-E network card somewhere that will work with OI.

Actions

Also available in: Atom PDF