Project

General

Profile

Bug #1376

savecore: bad magic number, savecore -L hangs

Added by Olaf Bohlen almost 9 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cmd - userland programs
Start date:
2011-08-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Hi,

I'm running OI 151 on amd64 (http://pkg.openindiana.org/dev-il/) and while I tried to savecore a kernel dump, it tells me

(583) oldn90700:/root# savecore -v
savecore: bad magic number ba5fbbf7

Just to verify that kernel dumps are written correctly, I tried savecore -L:

(584) oldn90700:/root# savecore -L
dumping to /dev/zvol/dsk/rpool/dump, offset 65536, content: all
1:29 99% done
and here it hangs until eternity...at least truss -fpi `pgrep savecore` does not show anything, so it seems to hang in a syscall.

I can however attach to a running kernel via mdb -k and also break the machine while running the kmdb.

This sounds like http://wesunsolve.net/bugid/id/6996868 to me...

History

#1

Updated by Rich Ercolani almost 9 years ago

bug 1369 likely has the workaround that will make your life nicer

#2

Updated by Olaf Bohlen almost 9 years ago

Indeed, you are right. This is a duplicate

#3

Updated by Olaf Bohlen 12 months ago

  • Status changed from New to Closed

duplicate of #1369

Also available in: Atom PDF