Project

General

Profile

Actions

Bug #13826

closed

lofi: delayed mapping deletion can panic due to NULL ls_stacked_vp

Added by Toomas Soome about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
driver - device drivers
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

panic message: BAD TRAP: type=e (#pf Page fault) rp=fffffe0008a20420 addr=28 occurred in module "genunix" due to a NULL pointer dereference

::stack

vnodetopath_common+0x290(0, 0, fffffe06623b2554, 400, fffffe065bb1a810, 0)
vnodetopath+0x24(0, 0, fffffe06623b2554, 400, fffffe065bb1a810)
lofi_get_info+0x191(8100000000, 80457dc, 4c4605, fffffe065bb1a810, 100401)

When mapping is deleted while still in use (lofiadm -d -f) the mapping will be removed, ls_stacked_vp is set to NULL and if we now call vnodetopath(), the system will panic.

Testing done: confirmed, we do not get panic any more.

Actions #1

Updated by Electric Monk about 1 year ago

  • Gerrit CR set to 1512
Actions #2

Updated by Electric Monk about 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

git commit e31da75739e46b82cd7fdd6e51590fefa97cc9c0

commit  e31da75739e46b82cd7fdd6e51590fefa97cc9c0
Author: Toomas Soome <tsoome@me.com>
Date:   2021-05-21T21:48:06.000Z

    13826 lofi: delayed mapping deletion can panic due to NULL ls_stacked_vp
    Reviewed by: Robert Mustacchi <rm@fingolfin.org>
    Reviewed by: Gordon Ross <gordon.w.ross@gmail.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF