Project

General

Profile

Actions

Bug #13858

open

x11 hot plug keyboard does not work

Added by Ben Franck over 1 year ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

If I unplug-replug usb keyboard, I loose it.
If I plug another usb keyboard, it does not work.
If I restart lightdm/X11 (disable/enable lightdm), I get the keyboard back

Hotplugging keyboard on the text console works fine, it is only X11.

It used to work, the most recent be I have where usb keyboard hotplug works is from 7/12/2020 (illumos-06524cf4e4, 2020.4).
It stopped working when I updated the be on the 15/04/2021 (illumos-15276eb5b5, 2020.10)


Related issues

Related to OpenIndiana Distribution - Bug #14226: service/hal needs restart after hardware changeResolved

Actions
Actions #1

Updated by Gary Mills over 1 year ago

I've seen two related problems with a recent OI upgrade. One is that my KVM will no longer reconnect my USB keyboard to any OI system. The other is that OI will no longer automount USB sticks. Both used to work. I verified the second one by booting an older BE on the system. The common factor seems to be USB. I've verified that hal no longer notices changes in USB devices. USB is close to the boundary between OI and illumos. lightdm is on the OI side. I wonder if lightdm or perhaps Xorg is the culprit.

Actions #2

Updated by David Stes about 1 year ago

  • Related to Bug #14226: service/hal needs restart after hardware change added
Actions

Also available in: Atom PDF