Project

General

Profile

Actions

Bug #13905

closed

zfs holds is quadratic

Added by Andrew Stormont 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

zfs holds calls zfs_for_each for each argument it is given which it turn iterates over the complete set of arguments. At first glance its use of zfs_for_each seems unnecessary but it must use it to properly support recursive lookups. The fix is to only pass only one argument at a time to zfs_for_each.


Related issues

Is duplicate of illumos gate - Bug #1869: "zfs holds" is O(n^2)NewAndrew Stormont2011-12-08

Actions
Actions #1

Updated by Electric Monk 7 months ago

  • Gerrit CR set to 1570
Actions #2

Updated by Andrew Stormont 7 months ago

I have a fix out for review here: https://code.illumos.org/c/illumos-gate/+/1570

Testing: I verified that the output of the zfs holds command didn't change.

Actions #3

Updated by Electric Monk 7 months ago

  • Status changed from In Progress to Closed

git commit 1e9e241fbdc7ae75a7b37c1e7afc8c96d2f43e1e

commit  1e9e241fbdc7ae75a7b37c1e7afc8c96d2f43e1e
Author: Andrew Stormont <astormont@racktopsystems.com>
Date:   2021-07-04T10:13:40.000Z

    13905 zfs holds is quadratic
    Reviewed by: Alexander Stetsenko <alex.stetsenko@gmail.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Vitaliy Gusev <gusev.vitaliy@gmail.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions #4

Updated by Andrew Stormont 6 months ago

  • Is duplicate of Bug #1869: "zfs holds" is O(n^2) added
Actions

Also available in: Atom PDF