Project

General

Profile

Actions

Bug #13933

closed

zero-sized kmem_alloc() in zfs`spa_load_l2cache

Added by Andy Fiddaman 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
zfs - Zettabyte File System
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

OmniOS r151039 Version omnios-upstream_merge-2021070801-adc6d6fc9b 64-bit
Copyright (c) 2012-2017 OmniTI Computer Consulting, Inc.
Copyright (c) 2017-2021 OmniOS Community Edition (OmniOSce) Association.
DEBUG enabled
WARNING: kmem_alloc(): sleeping allocation with size of 0; see kmem_zerosized_ls
WARNING: kmem_alloc(): sleeping allocation with size of 0; see kmem_zerosized_ls
> ::kmalog zerosized

T-0.000000000  addr=0  0
         kmem_log_event+0x9b
         kmem_alloc+0x17d
         spa_load_l2cache+0x328
         spa_ld_open_aux_vdevs+0x158
         spa_load_impl+0x17e
         spa_load+0x5d
         spa_load_best+0x6c
         spa_open_common+0x118
         spa_open+0x15
         dsl_pool_hold+0x3f
         dsl_dsobj_to_dsname+0x35
         zfs_parse_bootfs+0xb4
         zfs_mountroot+0xf6
         fsop_mountroot+0x13
         rootconf+0x170

T-0.001949228  addr=0  0
         kmem_log_event+0x9b
         kmem_alloc+0x17d
         spa_load_l2cache+0x97
         spa_ld_open_aux_vdevs+0x158
         spa_load_impl+0x17e
         spa_load+0x5d
         spa_load_best+0x6c
         spa_open_common+0x118
         spa_open+0x15
         dsl_pool_hold+0x3f
         dsl_dsobj_to_dsname+0x35
         zfs_parse_bootfs+0xb4
         zfs_mountroot+0xf6
         fsop_mountroot+0x13
         rootconf+0x170

Related issues

Is duplicate of illumos gate - Bug #6161: zero-sized kmem_alloc() in zfs`spa_load_l2cacheClosedAndy Fiddaman2015-08-24

Actions
Actions #1

Updated by Andy Fiddaman 4 months ago

  • Is duplicate of Bug #6161: zero-sized kmem_alloc() in zfs`spa_load_l2cache added
Actions #2

Updated by Andy Fiddaman 4 months ago

  • Description updated (diff)
Actions #3

Updated by Andy Fiddaman 4 months ago

  • Status changed from In Progress to Duplicate
Actions #4

Updated by Andy Fiddaman 4 months ago

  • Assignee deleted (Andy Fiddaman)
Actions

Also available in: Atom PDF