Project

General

Profile

Bug #1399

oi_151, wireless signals not detected on laptop

Added by Fred Kimball over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Drivers
Target version:
Start date:
2011-08-22
Due date:
2011-09-14
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
ath

Description

Wireless signals are not detected on a Sony Vaio laptop equipped with an Atheros (AR5001) wireless network adapter when booted in oi_151. oi_148 was initially installed in this computer and wireless signals are detected and obtains an IP address from the router when booted into oi_148.

History

#1

Updated by Chris Jordan over 8 years ago

  • Category set to Drivers
  • Assignee set to OI illumos
  • Tags changed from needs-triage to wifi
#2

Updated by Ken Mays over 8 years ago

  • Due date set to 2011-09-14
  • Status changed from New to Feedback
  • Target version set to oi_151_stable
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
  • Tags changed from wifi to ath

Use driver/network/ath 0.5.11,5.11-0.151.1:20110912T030951Z on oi_151a.

#3

Updated by Garrett D'Amore over 8 years ago

I wonder if this is another item of fall out caused by 534, such 1402.

Would be interesting to know if the latest kernel with the cache tweaks backed out works properly.

I don't recall seeing anything specific to wifi changing in the interim, at any rate.

#4

Updated by Fred Kimball over 8 years ago

Hello Ken and Garrett.

The pkg you mention has a later time stamp that what is currently installed, so hopefully the issue is fixed in oi_151_stable. No update is showing in the oi_151a repo. Here is my output of pkg info:
~$ pkg info ath
Name: driver/network/ath
Summary: Atheros 802.11b/g Wireless NIC Driver
Description: Atheros AR52xx 802.11b/g Wireless NIC Driver
Category: Drivers/Networking
State: Installed
Publisher: openindiana.org
Version: 0.5.11
Build Release: 5.11
Branch: 0.151.1
Packaging Date: August 18, 2011 08:52:32 PM
Size: 765.83 kB
FMRI: pkg:,5.11-0.151.1:20110818T205232Z

#5

Updated by Ken Mays over 8 years ago

Fred - can you do this:
1. pfexec pkg refresh --full
2. pfexec pkg image-update -v
3. reboot

This will let you test the recent kernel updates with the ath driver I mentioned.

#6

Updated by Fred Kimball over 8 years ago

Ken, good news, I'm now connected through the wireless connection. So you can mark this bug closed. I had pkgs from sfebuild which did not refresh, so had to unset and check the wiki for it's replacement. image-update required package/pkg to be updated first.

Thank you for your help and everyone else on the illumos and oi team!

#7

Updated by Ken Mays over 8 years ago

  • Status changed from Feedback to Resolved

Resolved, per user's request.

Also available in: Atom PDF