Project

General

Profile

Bug #1402

fix for #534 causes dire performance regression

Added by Phil Harrison almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
kernel
Start date:
2011-08-23
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
ixbge

Description

After doing a clean install to OpenIndiana 151 I noticed that iperf was only showing about 5% utilization of the ixbge0 adapter. Previously in OpenIndiana 148 this figure was around 85-90%.


Related issues

Related to illumos gate - Bug #534: DMA KVA cache attributes incorrectRejected2010-12-17

Actions
Has duplicate site - Bug #1401: ixgbe intel 10gbit driver very slowClosed2011-08-23

Actions

History

#1

Updated by Chris Jordan almost 8 years ago

  • Assignee set to OI illumos
  • Priority changed from High to Normal
  • Tags changed from needs-triage to ixbge
#2

Updated by Phil Harrison almost 8 years ago

ip module from SmartOS distribution fixes issue, suggest upgrade in illumos.

#3

Updated by Dan McDonald almost 8 years ago

If the Joyent IP module fixes the problem, I believe this is a regression/bug introduced by #1361. Stay tuned to see if I'm right.

#4

Updated by Dan McDonald almost 8 years ago

While #1361 does need a tiny fix, it was not the cause of the regression.

#534, a fix to ddi_dma_mem_alloc(), caused the regression. The simple thing would be to back it out. A suggestion of further analysis was recommended. Stay tuned to see what happens.

#5

Updated by Rich Lowe almost 8 years ago

  • Project changed from OpenIndiana Distribution to illumos gate
  • Category deleted (Drivers)
  • Target version deleted (oi_151_stable)
#6

Updated by Rich Lowe almost 8 years ago

  • Subject changed from ixgbe intel 10gbit driver very slow to fix for #534 causes dire performance regression
  • Assignee deleted (OI illumos)
#7

Updated by Rich Lowe almost 8 years ago

  • Category set to kernel
  • Status changed from New to Resolved
  • Assignee set to Dan McDonald
  • % Done changed from 0 to 100

Resolved in r13441 commit:99f81276ef96

#8

Updated by Bill Sommerfeld almost 8 years ago

FYI: I have a very limited sample size, (2 working reboots with this fix, a half dozen broken reboots without it)
I believe backing out #534 may have fixed the atheros driver on my ferrari4000. (the f4k came with a broadcom minipci card which doesn't have a native solaris driver; like others, I replaced it with an aftermarket Atheros mini-pci card which identifies in scanpci as an "AR5001X+", vendor 0x168c/device 0x0013)

With either stock oi_151a from openindiana's dev-il repo, or stock oi_151a plus a genunix I built from changeset 13440:49d0a9c4f724 (the changeset before the backout), the laptop will not connect to my home wifi network; dladm scan-wifi shows no networks.

with a genunix built against changeset 13441:99f81276ef96 (current tip, with the backout), the laptop connects as expected.

Note that I haven't dug deeply into the misbehaving ath to see precisely how it's misbehaving but I can do that if anyone's morbidly curious.

Also available in: Atom PDF