Project

General

Profile

Actions

Bug #14099

closed

14073 breaks gcc4 builds on x86, should be SPARC-only

Added by Dan McDonald 25 days ago. Updated 25 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
lib - userland libraries
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

The fix for 14073 breaks SmartOS's gcc4 pipeline. The problem and fix are here: https://gist.github.com/danmcd/5084e202694b83d01904837de8cd1617

diff --git a/usr/src/lib/krb5/plugins/kdb/ldap/Makefile.com b/usr/src/lib/krb5/plugins/kdb/ldap/Makefile.com
index 67cdcc5980..dcdaf24b3d 100644
--- a/usr/src/lib/krb5/plugins/kdb/ldap/Makefile.com
+++ b/usr/src/lib/krb5/plugins/kdb/ldap/Makefile.com
@@ -66,7 +66,8 @@ CERRWARN +=   -_gcc=-Wno-unused-function

 DYNFLAGS +=    $(KERBRUNPATH)
 # setting -L $(ROOT)/usr/lib/gss because libkdb_ldap needs mech_krb5
-LDLIBS +=      -L $(ROOT)/usr/lib/gss -L $(ROOTLIBDIR) -lkdb_ldap -lc
+LDLIBS +=      -L $(ROOT)/usr/lib/gss -L $(ROOTLIBDIR) -lkdb_ldap
+$(SPARC_BLD)LDLIBS += -lc

 .KEEP_STATE:


Related issues

Related to illumos gate - Bug #14073: kdb/ldap: symbol referencing errorsClosedToomas Soome

Actions
Related to illumos gate - Bug #14135: SPARC build errors remove SPARC_BLD link option from lib/krb5/plugins/kdb/ldap/Makefile.comNewKlaus Ziegler

Actions
Actions #1

Updated by Dan McDonald 25 days ago

  • % Done changed from 0 to 90
Actions #2

Updated by Joshua M. Clulow 25 days ago

  • Related to Bug #14073: kdb/ldap: symbol referencing errors added
Actions #3

Updated by Dan McDonald 25 days ago

Tested by building with gcc4 on SmartOS, and by a regression-test of illumos-gate with this fix in place.

Actions #4

Updated by Electric Monk 25 days ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

git commit fdd257eae4dc81bf98126bf8010bb705761a232a

commit  fdd257eae4dc81bf98126bf8010bb705761a232a
Author: Dan McDonald <danmcd@joyent.com>
Date:   2021-09-22T21:16:05.000Z

    14099 14073 breaks gcc4 builds on x86, should be SPARC-only
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Joshua M. Clulow <josh@sysmgr.org>

Actions #5

Updated by Andy Fiddaman 12 days ago

  • Related to Bug #14135: SPARC build errors remove SPARC_BLD link option from lib/krb5/plugins/kdb/ldap/Makefile.com added
Actions

Also available in: Atom PDF