Project

General

Profile

Actions

Feature #14111

closed

Update mandoc to 1.14.6

Added by Robert Mustacchi 4 months ago. Updated 11 days ago.

Status:
Closed
Priority:
Normal
Category:
cmd - userland programs
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

mandoc 1.14.6 was released. We should update the mandoc in illumos to the latest release. To help prepare for this I was involved in prerelease testing and did the following:

  • Verified that the tools and cmd builds of mandoc were good and used the new mandoc for the check targets
  • diffed every manual page in illumos to see what changed in what was generated. This uncovered some bugs and also a few small changes which are all due to known changes in mandoc and improvements there
  • Ran through the regression test suite of mandoc
Actions #1

Updated by Robert Mustacchi 4 months ago

  • Gerrit CR set to 1729
Actions #2

Updated by Electric Monk 11 days ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 4d131170e62381276a07ffc0aeb1b62e527d940c

commit  4d131170e62381276a07ffc0aeb1b62e527d940c
Author: Robert Mustacchi <rm@fingolfin.org>
Date:   2022-01-05T17:44:35.000Z

    14111 Update mandoc to 1.14.6
    Reviewed by: Yuri Pankov <ypankov@tintri.com>
    Reviewed by: Rich Lowe <richlowe@richlowe.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF