Project

General

Profile

Actions

Bug #14133

closed

rlogind: ioctl I_LINK of tcp connection failed

Added by Klaus Ziegler about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
kernel
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

rlogind is broken in ONV=20712, last version I was running which was working okay is ONV=20673,
sorry to not narrow it down further more. However rsh in non-interactive mode still works:

rsh <hostname> "uname -a"

still works fine, while:

rsh/rlogin "<hostname" are returning:
rlogind: ioctl I_LINK of tcp connection failed
.
Connection to <hostname> closed.


Related issues

Related to illumos gate - Bug #14098: handle failure when muxing non-device streamsClosedRich Lowe

Actions
Actions #1

Updated by Klaus Ziegler about 2 months ago

  • Description updated (diff)
Actions #2

Updated by Joshua M. Clulow about 2 months ago

  • Related to Bug #14098: handle failure when muxing non-device streams added
Actions #3

Updated by Rich Lowe about 2 months ago

  • Assignee set to Rich Lowe

I think this is because this does things slightly differently than the other case, and our historical behaviour here has just been to ignore it and not set up the LDI integration. I'm testing a fix now.

(this opens the possibility that the other fix could have just checked both sides and bailed early too, but I'm still wanting to be more conservative with that.)

Actions #4

Updated by Rich Lowe about 2 months ago

This is the case. Previously if the bottom wasn't a device we'd just return 0 before even beginning setting up with LDI, and thus succeed. We should preserve this behaviour, which turns out to be easy to do.

This suggests that the fix for #14098 could perhaps also succeed without ever trying to set up the LDI link, but in the interests of being conservative about it, I'm not changing that right now. (despite, yes, not having been conservative enough initially. Sorry).

testing:

rlogin as described works, gets a real workable shell.
reproduction testing of #14098 still passes
Actions #5

Updated by Electric Monk about 2 months ago

  • Gerrit CR set to 1739
Actions #6

Updated by Electric Monk about 1 month ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 2d2dd8359f765a17f6caaa2d37d86837c0c40915

commit  2d2dd8359f765a17f6caaa2d37d86837c0c40915
Author: Richard Lowe <richlowe@richlowe.net>
Date:   2021-10-06T19:30:42.000Z

    14133 rlogind: ioctl I_LINK of tcp connection failed
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Andy Fiddaman <andy@omnios.org>
    Reviewed by: Klaus Ziegler <klausz@haus-gisela.de>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF