Bug #1424

Upgrading from 2010.05 (134b) fails

Added by daniel kho almost 6 years ago. Updated over 5 years ago.

Status:ResolvedStart date:2011-08-29
Priority:HighDue date:2011-09-14
Assignee:Jon Tibble% Done:

100%

Category:Release EngineeringEstimated time:8.00 hours
Target version:oi_151_stable
Difficulty:Medium Tags:image-update

Description

Sorry for a duplicate post. I found out that "OI Community Hub/Branding" wasn't the right place to report issues, and just bumped into this section today.
So feel free to remove my post under Branding. Anyway, here it is again:

I got the following error when trying to upgrade from 2010.05 to OpenIndiana. What could I have done wrong?

dan@opensolaris:~# uname -a
SunOS opensolaris 5.11 snv_134b i86pc i386 i86pc
dan@opensolaris:~#
dan@opensolaris:~# pfexec pkg image-update -vCreating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.147:20100914T035208Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.147:20110720T213831Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20101122T085607Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20110720T213932Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

I followed the guide in http://wiki.openindiana.org/oi/Installing+or+Upgrading.

pkg-list.log Magnifier (60.3 KB) daniel kho, 2011-08-29 12:08 PM

pkg-debug.log Magnifier (1.28 MB) daniel kho, 2011-09-12 06:44 AM

History

#1 Updated by Piotr Jasiukajtis almost 6 years ago

Please provide your output from 'pkg publisher' and upload file with 'pkg list'.

#2 Updated by daniel kho almost 6 years ago

Piotr Jasiukajtis wrote:

Please provide your output from 'pkg publisher' and upload file with 'pkg list'.

daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
opensolaris.org (preferred) origin online http://pkg.openindiana.org/legacy/
openindiana.org origin online http://pkg.openindiana.org/dev/
daniel-kho@opensolaris-bts-daniel:~# pfexec pkg install SUNWipkg SUNWipkg-um SUNWipkg-gui
No updates necessary for this image.
daniel-kho@opensolaris-bts-daniel:~# pfexec pkg set-publisher -P openindiana.org
daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org origin online http://pkg.openindiana.org/legacy/
daniel-kho@opensolaris-bts-daniel:~# pfexec pkg image-update -v
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.147:20100914T035208Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.147:20110720T213831Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20101122T085607Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20110720T213932Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

daniel-kho@opensolaris-bts-daniel:~# pkg list > /tmp/pkg-list.log

#3 Updated by Rich Lowe almost 6 years ago

  • Project changed from illumos gate to OpenIndiana Distribution

#4 Updated by Fred Kimball almost 6 years ago

The directions in the wiki say that the publisher "opensolaris.org" needs to be set to non-sticky. Both of my systems are set to that. Try

pfexec pkg set-publisher --non-sticky opensolaris.org

#5 Updated by daniel kho almost 6 years ago

I tried that as well, same results:

daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org (non-sticky) origin online http://pkg.openindiana.org/legacy/

daniel-kho@opensolaris-bts-daniel:~# pfexec pkg image-update -v
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.147:20100914T035208Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.147:20110720T213831Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20101122T085607Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20110720T213932Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

#6 Updated by Fred Kimball almost 6 years ago

I noticed from your pkg-list.log that:
package/pkg (solaris) 0.5.11-0.134.0.2 installed u----
package/pkg/package-manager (solaris) 0.5.11-0.134.0.2 installed u----

are using a (solaris) repo instead of (opensolaris.org).

Try pfexec pkg update -nv The -n flag executes the requested operation but makes no change to the image. I suspect you need to install a newer version of pkg.

The wiki page you linked to includes this for failure to update:
The following script can be run to help determine why image-update does nothing OR fails to update as many packages as you expect. It applies to the OpenIndiana release, not to image-updates from the legacy repo.

pfexec pkg install --no-refresh -nv

#7 Updated by daniel kho almost 6 years ago

How do I change my pkg from solaris to openindiana? I guess I tried to upgrade to Solaris 11 Express before changing my mind to openindiana.

daniel-kho@opensolaris-bts-daniel:~# pfexec pkg update -nv
pkg: unknown subcommand 'update'
Try `pkg --help or -?' for more information.

When I do a "pfexec pkg image-update -nv", I got the same errors as before.
Same result after executing "pfexec pkg install pkg:/package/pkg".

Is it possible for me to uninstall and reinstall pkg (so I can get openindiana's version)?

#8 Updated by Fred Kimball almost 6 years ago

Hello Daniel,

I've been using osol since 2009.06. I've learned a lot, but still I'm no expert.

FYI, I noticed from your entries
daniel-kho@opensolaris-bts-daniel:~#
The "#" indicates you have used the su command to become root in which case it's not necessary to preface commands which affect the system with pfexec. If you were to type in "exit" (without quotes), it would change to
daniel-kho@opensolaris-bts-daniel:~$
It would then be necessary to use pfexec.

Since you say you tried to upgrade to Solaris 11 Express would explain why pkg and package-manager were installed by the (solaris) repo. My suggestion would be to set the preferred publisher to opensolaris.org and then try to install pkg and package-manager. e.g.

# pkg set-publisher -P opensolaris.org
# pkg install pkg package-manager

Hopefully they install. Then set openindiana.org as the preferred publisher and try image-update. If image-update still fails, do you get any FAIL or OBSOLETE pkgs that need to be removed from

# pkg install --no-refresh -nv

#9 Updated by daniel kho almost 6 years ago

Ok, I got something different now. Thanks for the tip on pfexec (I'm new to OpenSolaris/Indiana myself).

daniel-kho@opensolaris-bts-daniel:~# pkg set-publisher -P opensolaris.org
daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
opensolaris.org (non-sticky, preferred) origin online http://pkg.openindiana.org/legacy/
openindiana.org origin online http://pkg.openindiana.org/dev/

daniel-kho@opensolaris-bts-daniel:~# pkg install pkg package-manager
Creating Plan
pkg: 'pkg' matches multiple packages
package/pkg
system/management/rad/pkg

daniel-kho@opensolaris-bts-daniel:~# pkg install package/pkg package-manager
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://opensolaris.org/package/,5.11-0.133:20100216T141949Z: Newer version pkg://solaris/package/,5.11-0.134.0.2:20101027T183316Z is already installed

pkg://opensolaris.org/package/,5.11-0.133:20100218T000555Z: Newer version pkg://solaris/package/,5.11-0.134.0.2:20101027T183316Z is already installed

pkg://opensolaris.org/package/,5.11-0.134:20100302T042843Z: Newer version pkg://solaris/package/,5.11-0.134.0.2:20101027T183316Z is already installed

daniel-kho@opensolaris-bts-daniel:~# uname -a
SunOS opensolaris-bts-daniel 5.11 snv_134b i86pc i386 i86pc Solaris

daniel-kho@opensolaris-bts-daniel:~# pkg set-publisher -P -O http://pkg.opensolaris.org/release opensolaris.org

daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
opensolaris.org (non-sticky, preferred) origin online http://pkg.opensolaris.org/release/
openindiana.org origin online http://pkg.openindiana.org/dev/

daniel-kho@opensolaris-bts-daniel:~# pkg image-update -nv
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://opensolaris.org/package/,5.11-0.134.0.2:20100529T001816Z: Newer version pkg://solaris/package/,5.11-0.134.0.2:20101027T183316Z is already installed

Looks like it doesn't allow me to overwrite my current pkg when it says I have a newer version already installed.

#10 Updated by Fred Kimball almost 6 years ago

The install command installs or updates to a newer version the pkg currently installed.

"Creating Plan
pkg: 'pkg' matches multiple packages
package/pkg
system/management/rad/pkg"

The ImagePackageSystem has a web interface where you can browse or search for a package and install using the install link. I opened http://pkg.openindiana.org/dev/ in a new tab. system/management/rad/pkg is in oi_148.

What happened when you tried to upgrade to Solaris 11 Express? Were you able to boot into it? It appears to have updated some packages (pkg & package-manager) to a newer time stamp. i.e. pkg://solaris/package/,5.11-0.134.0.2:20101027T183316Z. pkg.opensolaris.org/release/ is 0.5.11,5.11-0.134.0.2:20100529T011137Z (your other pkgs from pkg-list.log indicate indicate the publisher as opensolaris.org version 0.5.11,5.11-0.134.0.2). I thought the original version of Solaris 11 Express was 151 or higher. Why are pkg and package-manager installed from (solaris) and the version is still 134b?

The part after the semicolon is the time stamp in year (yyyy), month (mm), day (dd), Time, hours, minutes, seconds, Zulu or the UTC.

I see you changed the preferred publisher to pkg.opensolaris.org/release/ which is the snv_134b. pkg.openindiana.org/legacy/ is a snapshot of pkg.opensolaris.org/dev/ which is what I still have. It id's as package/,5.11-0.134:20100302T042843Z.

opensolaris.org (non-sticky) origin online http://pkg.opensolaris.org/dev/

I now suggest that you make a clone of your current boot environment. If something gets messed up in an upgrade, you'll still have a working system to boot into. Take a look at: man beadm . I learned that the software for this bug reporting system interprets lines that begin with # as a numbered list and have to use the preformat option to include it.

beadm create beName (create a new name, i.e. current BeName-clone)

The directions in the wiki assumed your image was installed from snv_134 or snv_134b which would have been from the opensolaris.org repo. Since you had tried Solaris 11 Express, pkg and package-manager are from a different image and publisher (solaris). I'm guessing if (solaris) had been made non-sticky and you had not removed it, the upgrade to OI may have worked.

Add (set-publisher) and make it non-sticky the Solaris 11 Express publisher (I don't know what the uri is).

With --non-sticky, specify that higher ranked publishers than this one may provide updates to packages originally installed from this publisher.

pkg set-publisher -P openindiana.org

You should end up with
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org (non-sticky) origin online http://pkg.opensolaris.org/release/
solaris (non-sticky) origin online URI

Try another image-update.

I'm currently using oi_151 from /dev-il/ I see that OpenIndiana is trying to get a release out for the first anniversary. I have found a couple of bugs including a critical bug on a laptop - wireless signals are not detected. You might want to use http://pkg.openindiana.org/dev-il/ as the origin for the openindiana.org repo.

P.S. another pfexec tip. If your not root, i.e. $, and you issue a command that requires root permission (you'll get a notice), enter pfexec !! and the command will be performed.

#11 Updated by daniel kho almost 6 years ago

Hi Fred,
I didn't manage to boot into Solaris 11 Express as well. Something in the Python API caused me not to be able to make the upgrade.
And since the upgrade process stalled halfway, there were some packages such as pkg already updated to solaris 11.

Unfortunately I didn't clone my boot environment at that time, so there's no way for me to revert to before the upgrade.

Yes, so as not to screw other things up, I'm now working from my opensolaris 134b clone (this is with the upgraded solaris11 pkg).

I'll try with making solaris non-sticky, and will let you know how it goes.

#12 Updated by daniel kho almost 6 years ago

"Something in the Python API caused me not to be able to make the upgrade."
See https://defect.opensolaris.org/bz/show_bug.cgi?id=11723
and my initial post: https://defect.opensolaris.org/bz/show_bug.cgi?id=18871

#13 Updated by daniel kho almost 6 years ago

Ok, here's what I got:

daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org (non-sticky) origin online http://pkg.opensolaris.org/release/
solaris (non-sticky) origin online http://pkg.oracle.com/solaris/release/

daniel-kho@opensolaris-bts-daniel:~# pkg image-update -nv
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.147:20100914T035208Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.147:20110720T213831Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20101122T085607Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.148:20110720T213932Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

#14 Updated by Ken Mays almost 6 years ago

  • Due date set to 2011-09-14
  • Category set to PKG (Image Packaging System)
  • Status changed from New to Feedback
  • Assignee set to Alasdair Lumsden
  • Target version set to oi_151_stable
  • Estimated time set to 8.00

Daniel - the unofficial work is focused on upgrading from OpenSolaris snv_134b to OpenIndiana oi_151a - but this is not officially supported due to the developer state of the OpenSolaris/OpenIndiana project.

1. Read the Wiki notes per:
http://wiki.openindiana.org/oi/Installing+or+Upgrading
2. Only use the pkg.openindiana.org/dev-il repository for image updates.
3. unset pkg.oracle.com and pkg.openindiana.org/dev & /legacy publishers.
4. Provide feedback after making these changes and testing.

#15 Updated by daniel kho almost 6 years ago

Thanks Ken. I now did the following:
daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev-il/
opensolaris.org (non-sticky) origin online http://pkg.opensolaris.org/release/
solaris (non-sticky) origin online http://pkg.oracle.com/solaris/release/
daniel-kho@opensolaris-bts-daniel:~#
daniel-kho@opensolaris-bts-daniel:~#
daniel-kho@opensolaris-bts-daniel:~# pkg set-publisher -d solaris
daniel-kho@opensolaris-bts-daniel:~# pkg set-publisher -d opensolaris.org
daniel-kho@opensolaris-bts-daniel:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev-il/
opensolaris.org (non-sticky, disabled) origin online http://pkg.opensolaris.org/release/
solaris (non-sticky, disabled) origin online http://pkg.oracle.com/solaris/release/
daniel-kho@opensolaris-bts-daniel:~# pkg image-update -nv
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.148:20110411T145321Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.151:20110523T153203Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

#16 Updated by daniel kho almost 6 years ago

I did the following with the same results:

daniel-kho@opensolaris-bts-daniel:~# pkg install package/pkg package-manager
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.148:20110411T145321Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

pkg://openindiana.org/package/,5.11-0.151:20110523T153203Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

#17 Updated by daniel kho almost 6 years ago

I tried with --no-refresh, and seems like I get a similar message for IPS.

daniel-kho@opensolaris-bts-daniel:~# pkg install --no-refresh -nv pkg:/consolidation/ips/,5.11-0.148
Creating Plan /Planning for install failed:

pkg: No matching version of consolidation/ips/ips-incorporation can be installed:
pkg://openindiana.org/consolidation/ips/,5.11-0.148:20110411T145013Z: This version is excluded by installed incorporation pkg://opensolaris.org/,5.11-0.134.0.2:20100528T233058Z

#18 Updated by Alasdair Lumsden almost 6 years ago

Hi Daniel,

Are you able to visit #openindiana on irc.freenode.net (IRC - http://en.wikipedia.org/wiki/Internet_Relay_Chat) so I can have a chat with you about this?

Basically there are some things I'd like you to try to get a more helpful message out of pkg.

Cheers,

Alasdair

#19 Updated by Alasdair Lumsden almost 6 years ago

Hi All,

I can confirm that Dan was able to upgrade using:

pkg install -v pkg:/consolidation/ips/,5.11-0.151 pkg:/,5.11-0.151

Not sure why thats the case in this instance. If I get some time this week I'll test upgrading from OpenSolaris 134.0.2 to oi_151 via a normal image-update and see if it works.

Regards,

Alasdair

#20 Updated by daniel kho almost 6 years ago

Thanks a lot Alasdair. Finally I was able to install everything. Just before rebooting, I thought I should post the last few lines after doing that "pkg install":

Actuators:
refresh_fmri: svc:/system/logadm-upgrade:default
restart_fmri: svc:/application/opengl/ogl-select:default
restart_fmri: svc:/application/desktop-cache/pixbuf-loaders-installer:default
restart_fmri: svc:/application/desktop-cache/gconf-cache:default
restart_fmri: svc:/application/desktop-cache/input-method-cache:default
restart_fmri: svc:/system/rbac:default
restart_fmri: svc:/application/font/fc-cache:default
restart_fmri: svc:/system/manifest-import:default
restart_fmri: svc:/application/desktop-cache/icon-cache:default
restart_fmri: svc:/application/desktop-cache/mime-types-cache:default
restart_fmri: svc:/application/desktop-cache/desktop-mime-cache:default
reboot-needed: true

DOWNLOAD PKGS FILES XFER (MB)
Completed 945/945 56299/56299 693.6/693.6

pkg: Requested "install" operation would affect files that cannot be modified in live image.
Please retry this operation on an alternate boot environment.

Not sure if I should be any concerned about that last statement. Perhaps (and hopefully) not.

#21 Updated by daniel kho almost 6 years ago

Before and after reboot, I saw the following:

daniel-kho@opensolaris-bts-daniel:~# beadm list
BE Active Mountpoint Space Policy Created
-- ------ ---------- ----- ------ -------
openindiana-09042011 NR / 9.03G static 2011-09-04 02:18
opensolaris - - 81.26M static 2011-07-18 14:45
opensolaris-08132011 - - 32.55M static 2011-08-14 00:09

Looks like it didn't create a new BE for me to boot into, so rebooting got back the same environment as previously.

#22 Updated by daniel kho almost 6 years ago

I found this error in the log:
incorporate: consolidation/ips/
FAIL: no suitable newer version for installed pkg pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z
Ruled out pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z because: This version excluded by specified installation version

Any ideas? The whole log output is attached.

#23 Updated by Ken Mays almost 6 years ago

1. pfexec pkg refresh --full
2. pkg image-update --be-name new151a
3. beadm mount new151a /mnt
4. pkg -R /mnt/* image-update
5. beadm umount new151a
6. reboot

Also if you want new SFE packages:
pkg.openindiana.org/sfe
pkg.openindiana.org/sfe-encumbered

#24 Updated by Ken Mays almost 6 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100
  • Tags changed from needs-triage to image-update

Daniel - let us know if you are having any further issues. Closing ticket.

#25 Updated by daniel kho almost 6 years ago

  • Assignee changed from Alasdair Lumsden to Ken Mays
  • Status changed from Closed to Feedback
  • % Done changed from 100 to 80

daniel-kho@opensolaris-bts-daniel:~# pkg refresh --full
daniel-kho@opensolaris-bts-daniel:~# pkg image-update --be-name openindiana-09172011
Creating Plan /Planning for install failed:
Use -v option for more details

pkg: No matching version of package/pkg can be installed:
pkg://openindiana.org/package/,5.11-0.151.1:20110912T031338Z: This version is excluded by installed incorporation pkg://opensolaris.org/consolidation/ips/,5.11-0.134.0.2:20100528T230337Z

This was using the /dev-il repository. Using the /dev repos will give more errors.

#26 Updated by Ken Mays almost 6 years ago

  • Assignee changed from Ken Mays to Alasdair Lumsden

Daniel - Thanks for the update. I saw your previous note that everything installed correctly?

1. Remove the old ips-incorporation package and check the install of:
consolidation/,5.11-0.151.1:20110912T030807Z

We'd like to ensure your upgrade process goes as smooth as possible.

Alasdair - Ref Bug #1125

#27 Updated by daniel kho almost 6 years ago

I tried uninstalling the old ips-incorporation but that'll remove pkg.

daniel-kho@opensolaris-bts-daniel:~# pkg list -s | grep ips
consolidation/ips/ips-incorporation (opensolaris.org) ips consolidation incorporation
daniel-kho@opensolaris-bts-daniel:~# pkg uninstall -rv consolidation/ips/ips-incorporation

I now don't have any 'pkg' to do a 'pkg refresh --full' for example.

#28 Updated by daniel kho almost 6 years ago

sorry, my post came in a little too prematurely. Everything installed correctly, except ips-incorporation.
That was the only error in the log file (the 2nd one attached).

#29 Updated by daniel kho almost 6 years ago

I'm not too sure if it's anything to do with me trying to upgrade from snv_134b instead of snv_134?

#30 Updated by Nikola M. over 5 years ago

Update from Opensolaris 2009.06 and Over snv_134 form /legacy to Openindiana 151a does not work again.

As explained on Wiki, by Anonimous commenter, and confirmed bz another Anonzmous commenter and confirmed by me yestarday ,
Update fails on entire , opensolaris-backgrounds , opensolaris-backgrounds-extra and opensolaris-welcome
http://wiki.openindiana.org/oi/Upgrading+from+OpenSolaris

One needs to put in teese comands to be able to update to Openindiana from Opensoalris 134:
pfexec pkg uninstall entire
pfexec pkg uninstall gnome/theme/background/opensolaris-backgrounds
pfexec pkg uninstall gnome/theme/background/opensolaris-backgrounds-extra
pfexec pkg uninstall release/opensolaris-welcome

I found out that after update to Openindiana is done, (desktop background turns to GREEN because background is deleted with opensolaris backgrounds),
one can install manually entire and
new gnome/theme/background/os-backgrounds and
gnome/theme/background/os-backgrounds-extra and
release/os-welcome

But that is hardly elegant way to bring new users in.
I suppose someone ditched old opensolaris brending, changing OI /dev repository, without testing how that would affect upgrade process.
Besides, I would like to still have old backgrounds (maybe setting OI branding by default is enough) and to avoid "green screen on update" Design self-kill.

Not to mention that it tok me 2,5 days to find issue to upgrade and for that time
(and other that do not read wiki) upgrade to Openindiana was Broken. As it is now.

#31 Updated by Jon Tibble over 5 years ago

  • Category changed from PKG (Image Packaging System) to Release Engineering
  • Status changed from Feedback to Resolved
  • Assignee changed from Alasdair Lumsden to Jon Tibble
  • % Done changed from 80 to 100

Fixed in prestable3 (oi_151a4)

Also available in: Atom