Project

General

Profile

Actions

Bug #14241

closed

zfs test README should suggest a test disk size

Added by Jason King 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
tests
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

The current zfs test readme in usr/src/test/zfs-tests/doc/README only specifies that three scratch disks are required for testing. It does not give a minimum size. If the scratch disks are too small, it can lead to spurious test failures.

There was some guidance at some point in the past of a minimum disk size of 10GiB. This is no longer sufficient, and a minimum of 12GiB is known to work (likely any value just above 10GiB would work as well, but it's probably not worth the effort to find the exact limit as long as we're not gratuitously over the actual minimum).


Related issues

Is duplicate of illumos gate - Bug #14162: zfs-tests: document pre-requisitesClosedToomas Soome

Actions
Actions #1

Updated by Andy Fiddaman 6 months ago

  • Is duplicate of Bug #14162: zfs-tests: document pre-requisites added
Actions #2

Updated by Electric Monk 6 months ago

  • Status changed from New to Closed

git commit 31116d9acef4a8c61f08e5ae089e2d29f233988d

commit  31116d9acef4a8c61f08e5ae089e2d29f233988d
Author: Toomas Soome <tsoome@me.com>
Date:   2021-11-17T20:03:56.000Z

    14162 zfs-tests: document pre-requisites
    Reviewed by: Robert Mustacchi <rm@fingolfin.org>
    Reviewed by: Andy Fiddaman <andy@omnios.org>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF