Project

General

Profile

Actions

Feature #14274

closed

fix a few broken pkg aliases

Added by Robert Mustacchi 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
packaging
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

When we put together the changes to switch to the v2 manifests, there were a number of manifest errors that were found. Of these, there were three in particular that represented bugs in the manifest:

driver-network-dmfe.p15m: Here there's an alias of the form alias=pci128h,9102. I looked up in the history of what happened and there was actually a comment in the old SUNWdfme package of the following form:

#
# Okay, so 128h is not a legal PCI vendor id.  But apparently some SPARC
# firmware creates the node with this id.  Not sure why, possibly it is
# a firmware bug, possibly it was intended to prevent the driver from
# being used with 3rd party NICs.  Whatever the reason, it isn't relevant
# anymore, but we still have to support the old node.
#

So, this is a SPARC special. Given the SPARC IPD, we can drop it I believe.

driver-network-upf.p5m: This had two invalid entries, alias=usbb3p,109 and alias=usbb3p,901. b3p is not a valid vendor id. In looking at the history, this was due to an error from me when I imported this driver in #6930. Looking back at this, it turned out this was a typo for the vendor OCT who has a vendor ID of b39.

/system-kernel-platform.p5m: here in the pcipsy driver, there was a single alias of the form alias=pci. This didn't have any more information there that we could draw on. As this was just a SPARC alias I opted to just remove it.

Actions #1

Updated by Electric Monk 9 months ago

  • Gerrit CR set to 1832
Actions #2

Updated by Robert Mustacchi 8 months ago

For testing I just did full debug and non-debug builds.

Actions #3

Updated by Electric Monk 8 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit eabc1bc5e61dbfdd2fc3cb588315c864d621d500

commit  eabc1bc5e61dbfdd2fc3cb588315c864d621d500
Author: Robert Mustacchi <rm@fingolfin.org>
Date:   2021-12-17T14:30:13.000Z

    14274 fix a few broken pkg aliases
    Reviewed by: Andy Fiddaman <andy@omnios.org>
    Approved by: Rich Lowe <richlowe@richlowe.net>

Actions

Also available in: Atom PDF