Project

General

Profile

Actions

Feature #14289

closed

cxgbe: update firmware version to 1.26.4.0

Added by Rahul Lakkireddy 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
driver - device drivers
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Need to update to latest supported firmware 1.26.4.0 from Chelsio (cxgbe) for the T4/T5/T6 NICs.

Actions #1

Updated by Electric Monk 5 months ago

  • Gerrit CR set to 1847
Actions #2

Updated by Rahul Lakkireddy 5 months ago

Need to update to latest supported firmware from Chelsio (cxgbe) for the T4/T5/T6 NICs.

Tested the patch as follows on the Chelsio T62100-LP-CR NIC:

The firmware on Chelsio T62100-LP-CR NIC was version 1.24.3.0.

# kstat t4nex
module: t4nex                           instance: 0     
name:   config                          class:    nexus
        bus_speed                       3
        bus_type                        pci-express
        bus_width                       x16 lanes
        chip_ver                        96
        core_clock                      798611
        crtime                          37.448338077
        driver_version                  2.2.1.0
        ec_level                        000000000000000
        fw_vers                         1.24.3.0
        id                              T62100-LP-CR
        pci_device_id                   0x6407
        pci_vendor_id                   0x1425
        port_cnt                        2
        port_type                       100G/100G/-/-
        serial_number                   PT44160085
        snaptime                        78.467885640
        tp_vers                         0.1.23.2

After the reboot and update by driver, the firmware version on NIC is 1.26.4.0.

# kstat t4nex
module: t4nex                           instance: 0     
name:   config                          class:    nexus
        bus_speed                       3
        bus_type                        pci-express
        bus_width                       x16 lanes
        chip_ver                        96
        core_clock                      798611
        crtime                          40.935685204
        driver_version                  2.2.1.0
        ec_level                        000000000000000
        fw_vers                         1.26.4.0
        id                              T62100-LP-CR
        pci_device_id                   0x6407
        pci_vendor_id                   0x1425
        port_cnt                        2
        port_type                       100G/100G/-/-
        serial_number                   PT44160085
        snaptime                        99.984008905
        tp_vers                         0.1.23.2
Actions #3

Updated by Ryan Zezeski 5 months ago

I also went ahead and tested this against my two Chelsio NICs. I verified that it reported the newer firmware and that I could send data across the ports.

rpz@midgar:~$ kstat t4nex
module: t4nex                           instance: 0     
name:   config                          class:    nexus
        bus_speed                       3
        bus_type                        pci-express
        bus_width                       x8 lanes
        chip_ver                        81
        core_clock                      250000
        crtime                          236.033937996
        driver_version                  2.2.1.0
        ec_level                        000000000000000
        fw_vers                         1.26.4.0
        id                              T520-SO
        pci_device_id                   0x5407
        pci_vendor_id                   0x1425
        port_cnt                        2
        port_type                       10G/10G/-/-
        serial_number                   PT49170535
        snaptime                        346.709804588
        tp_vers                         0.1.4.9

module: t4nex                           instance: 0     
name:   fm                              class:    misc
        acc_err                         0
        crtime                          236.033953716
        dma_err                         0
        erpt_dropped                    0
        fm_cache_full                   0
        fm_cache_miss                   0
        snaptime                        346.709820288

module: t4nex                           instance: 0     
name:   stats                           class:    nexus
        crtime                          236.033947726
        snaptime                        346.709816548
        write_coal_failure              0
        write_coal_success              0

module: t4nex                           instance: 1     
name:   config                          class:    nexus
        bus_speed                       3
        bus_type                        pci-express
        bus_width                       x8 lanes
        chip_ver                        96
        core_clock                      500000
        crtime                          237.093863756
        driver_version                  2.2.1.0
        ec_level                        000000000000000
        fw_vers                         1.26.4.0
        id                              T6225-CR
        pci_device_id                   0x6401
        pci_vendor_id                   0x1425
        port_cnt                        2
        port_type                       25G/25G/-/-
        serial_number                   PT23170209
        snaptime                        346.709841488
        tp_vers                         0.1.23.2

module: t4nex                           instance: 1     
name:   fm                              class:    misc
        acc_err                         0
        crtime                          237.093877866
        dma_err                         0
        erpt_dropped                    0
        fm_cache_full                   0
        fm_cache_miss                   0
        snaptime                        346.709852877

module: t4nex                           instance: 1     
name:   stats                           class:    nexus
        crtime                          237.093872886
        snaptime                        346.709849127
        write_coal_failure              0
        write_coal_success              0

When first testing this I came across a peculiar error when trying to create an interface on one of the T5 ports, but for the life of me I can't reproduce it. So I'll just leave it as a note here (I don't think this error should block integration of this change).

Dec  9 15:56:19 midgar t4nex: [ID 867250 kern.warning] WARNING: t4nex0: Requested Port Capabilities x rejected, error 1245190#012
Dec  9 15:56:19 midgar t4nex: [ID 933239 kern.warning] WARNING: cxgbe3: start_link failed: 22
Actions #4

Updated by Rahul Lakkireddy 5 months ago

Ryan Zezeski wrote in #note-3:

I also went ahead and tested this against my two Chelsio NICs. I verified that it reported the newer firmware and that I could send data across the ports.

Thank you for testing and verifying the patch.

[...]

When first testing this I came across a peculiar error when trying to create an interface on one of the T5 ports, but for the life of me I can't reproduce it. So I'll just leave it as a note here (I don't think this error should block integration of this change).

[...]

We're looking into what could be leading to this warning. Can you please share following information to help us debug further?

1) Information about the cable and the port module (such as type of module/cable, etc.) that is plugged-in to the T5 port where the warning occurred.

2) Output of firmware device log (devlog) of the adapter on which the warning occurred. The firmware devlog can be dumped using following command. There is limited space available for the devlog, so this may need to be dumped twice; once when the driver is loaded initially and the other time when the interface is created on the T5 port.

# cxgbetool /dev/t4nex0 devlog

Thanks,
Rahul

Actions #5

Updated by Electric Monk 4 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 10d62c2d611bc06a99db9c4a1d96f67561b16687

commit  10d62c2d611bc06a99db9c4a1d96f67561b16687
Author: Rahul Lakkireddy <rahul.lakkireddy@chelsio.com>
Date:   2022-01-16T17:38:00.000Z

    14289 cxgbe: update firmware version to 1.26.4.0
    Reviewed by: Ryan Zezeski <ryan@oxide.computer>
    Reviewed by: Jason King <jason.brian.king+illumos@gmail.com>
    Approved by: Robert Mustacchi <rm@fingolfin.org>

Actions

Also available in: Atom PDF