Project

General

Profile

Actions

Bug #14297

closed

ipmgmtd crash on zone boot

Added by Andy Fiddaman 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

A number of OmniOS users have reported that zone networking is not coming up properly in recent OmniOS bloody builds. The common factor appears to be the use of the allowed-address zone net property. I have replicated this behaviour on OpenIndiana too.

$ uname -a
SunOS hipster 5.11 illumos-9ca05893fa i86pc i386 i86pc

$ zonecfg -z ipkg info net
net:
        address not specified
        allowed-address: 1.2.3.4/24
        physical: ipkg0
        defrouter: 1.2.3.5

core '16-ipmgmtd-1498' of 1498: /lib/inet/ipmgmtd
 feb7a2fb nvlist_free (8047d0c) + 19
 080597a0 ipmgmt_persist_if_exists (80aef9c, 2) + 4c
 080549e6 ipmgmt_ngz_persist_if () + 49
 08054b92 ipmgmt_db_init () + 116
 08054d4b ipmgmt_init () + 37
 08054e99 main     (0, feefa5c8) + aa
 0805444b _start_crt (1, 8047e34, fefcffef, 0, 0, 0) + 9a
 0805431a _start   (1, 8047ef0, 0, 8047f02, 8047f1c, 8047f34) + 1a

The problem is that the ipmgmt_get_ifinfo_nvl() function, introduced with #2554, has some early exit paths where it never initialises the passed nvlist pointer resulting in a crash when the calling function attempts to free it.


Related issues

Related to illumos gate - Feature #2554: ipadm needs IPMP configuration supportClosed2012-03-28

Actions
Actions #1

Updated by Andy Fiddaman 8 months ago

  • Related to Feature #2554: ipadm needs IPMP configuration support added
Actions #2

Updated by Andy Fiddaman 8 months ago

  • Description updated (diff)
Actions #3

Updated by Andy Fiddaman 8 months ago

With the associated fix in place, the zone boots properly and networking is up:

root@hipster:~# cp /tmp/ipmgmtd /zones/ipkg/root/lib/inet/ipmgmtd
root@hipster:~#
root@hipster:~# zoneadm -z ipkg boot; zlogin -C ipkg
[Connected to zone 'ipkg' console]
Loading smf(5) service descriptions: 111/111
Hostname: ipkg

ipkg console login: ~.

af@hipster:~$ pfexec zlogin ipkg
[Connected to zone 'ipkg' pts/2]
The illumos Project     illumos-9ca05893fa      December 2021
root@ipkg:~# ipadm
ADDROBJ           TYPE     STATE        ADDR
lo0/v4            static   ok           127.0.0.1/8
ipkg0/_a          from-gz  ok           1.2.3.4/24
lo0/v6            static   ok           ::1/128
Actions #4

Updated by Electric Monk 8 months ago

  • Gerrit CR set to 1852
Actions #5

Updated by Electric Monk 8 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 47c607a3073a2acd65c934fe1e6967b2aa0094d8

commit  47c607a3073a2acd65c934fe1e6967b2aa0094d8
Author: Andy Fiddaman <omnios@citrus-it.co.uk>
Date:   2021-12-10T20:29:24.000Z

    14297 ipmgmtd crash on zone boot
    Reviewed by: Dan McDonald <danmcd@joyent.com>
    Reviewed by: Hans Rosenfeld <rosenfeld@grumpf.hope-2000.org>
    Approved by: Rich Lowe <richlowe@richlowe.net>

Actions

Also available in: Atom PDF