Project

General

Profile

Bug #1431

packagemanager a noop?

Added by Richard PALO over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
PKG (Image Packaging System)
Target version:
Start date:
2011-08-31
Due date:
2013-12-10
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
jds

Description

Thought I try http://staticdev.uk.openindiana.org:10003 (on oi_151)
so I clicked on the packager manager icon. nada.
started a shell tried "packagemanager". nada
sudo packagemanager ... black hole
packagemanager --version .... nothing.

what gives? only the command line pkg command works.

richard@amilo:~$ pkg list -v package-manager
FMRI                                                             STATE      UFOXI
pkg://openindiana.org/package/pkg/package-manager@0.5.11,5.11-0.151:20110523T153204Z installé  -----


Related issues

Related to OpenIndiana Distribution - Bug #3874: Packagemanager core dumps with hipsterClosed2013-07-082013-12-10

Actions

History

#1

Updated by Chris Jordan over 8 years ago

  • Category set to PKG (Image Packaging System)
  • Status changed from New to Feedback
  • Assignee set to Chris Jordan

I am unable to reproduce this problem on oi_151 or oi_151a (installed for English language & us-english keyboard), so we may not be able to do much to help. Is there anything you haven't mentioned about your installation that could help us reproduce the problem?

From the command line "packagemanager --version" should return "option --version not recognized, for help use --help". You don't even get that?

/usr/bin/packagemanager is a python script, is there anything unusual about your python installation? Do the other graphical admin tools written in python work, like update manager or time-slider?

#2

Updated by Richard PALO over 8 years ago

having installed the tar files for firefox 6 and thunderbird 6, I had uninstalled firefox and thunderbird (v3) from pkg.

I noticed the following in a new image-update from 148 before the operation:

richard@amilo:~$ sudo pkg uninstall -rnv firefox thunderbird
Mot de passe : 
                Packages à supprimer :     7
           Créer un environnement d'initialisation :   Non
               Services à redémarrer :     3
              Rebuild boot archive:   Non
fmri modifiés :
  pkg://openindiana.org/library/python-2/python-gtk-vnc-26@0.3.10,5.11-0.151:20110523T145318Z -> None
  pkg://openindiana.org/gnome/help-viewer/yelp@0.5.11,5.11-0.151:20110523T144210Z -> None
  pkg://openindiana.org/library/python-2/python-gnome-extras-26@0.5.11,5.11-0.151:20110523T145306Z -> None
  pkg://openindiana.org/library/python-2/python-gnome-extras-24@0.5.11,5.11-0.151:20110523T145306Z -> None
  pkg://openindiana.org/web/browser/firefox@0.5.11,5.11-0.151:20110523T150545Z -> None
  pkg://openindiana.org/mail/thunderbird@0.5.11,5.11-0.151:20110523T145435Z -> None
  pkg://openindiana.org/library/desktop/gtk-vnc@0.3.10,5.11-0.151:20110523T144821Z -> None
Services :
  restart_fmri: svc:/application/desktop-cache/gconf-cache:default
  restart_fmri: svc:/application/desktop-cache/icon-cache:default
  restart_fmri: svc:/application/desktop-cache/desktop-mime-cache:default

Before the uninstall operation packagemanager worked.
Why do these python packages need firefox?
Why would packagemanager need these if the dependency is not explicitly set?
something's hosed

#3

Updated by Chris Jordan over 8 years ago

  • Status changed from Feedback to New
  • Assignee changed from Chris Jordan to OI PKG
  • Tags changed from needs-triage to package-manager

Thank you. I can duplicate the problem you reported if I uninstall firefox first, then try to run package-manager. If I reinstall python-gnome-extras-26 (which also reinstalls firefox, since it depends on firefox), then package-manager works again. Looks like something in python-gnome-extras-26 is needed by package-manager, but python-gnome-extras-26 is not listed as a dependency of package-manager. I'm assigning this to OI PKG.

#4

Updated by Ken Mays over 8 years ago

  • Due date set to 2011-09-16
  • Category changed from PKG (Image Packaging System) to Desktop (JDS)
  • Status changed from New to Closed
  • Assignee changed from OI PKG to OI JDS
  • Priority changed from Normal to Low
  • Target version set to oi_151_stable
  • Estimated time set to 1.00 h
  • Difficulty changed from Medium to Expert
  • Tags changed from package-manager to jds

Richard - this is how it is handled upstream and implemented in their packages. There is nothing for us to do on this end as we implement based on what the JDS team is doing at the moment. As long as it is installed properly, everything should work fine. If not, surely reopen this ticket.

#5

Updated by Albert Lee over 8 years ago

  • Category changed from Desktop (JDS) to PKG (Image Packaging System)
  • Status changed from Closed to New
  • Assignee changed from OI JDS to OI PKG
  • Difficulty changed from Expert to Bite-size

We are responsible for fixing bugs.

#6

Updated by Ken Mays over 6 years ago

The Package Manager icon can be 'fixed' by modifying its command line properties to just '/usr/bin/packagemanager' which will launch the GUI app.
See: ,5.11-0.151.1.8:20130305T144819Z

#7

Updated by Ken Mays over 6 years ago

  • Due date changed from 2011-09-16 to 2013-12-10
  • Status changed from New to Closed
  • % Done changed from 0 to 100

packagemanager is now decommissioned by Upstream and OI. Use pkg tools within CLI.

Also available in: Atom PDF