Bug #1433

VLC: Segmentation Fault (core dumped)

Added by Predrag Zečević over 2 years ago. Updated over 2 years ago.

Status:Resolved Start date:2011-08-31
Priority:Low Due date:2011-09-29
Assignee:- % Done:

100%

Category:-
Target version:- Estimated time:8.00 hours
Difficulty:Expert Tags:vlc

Description

$ head -1 /etc/release
OpenIndiana Development oi_151 X86 (powered by illumos)

$ uname -rv
5.11 oi_151a

$ pkg publisher -a
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev-il/
opensolaris.org (non-sticky) origin online http://pkg.openindiana.org/legacy/
sfebuild origin online http://staticdev.uk.openindiana.org:10003/

$ pfexec pkg refresh --full
$ pfexec pkg update -v
Packages to update: 3
Create boot environment: No
Rebuild boot archive: No
Changed fmris:
pkg://sfebuild/library/video/,5.11-0.148:20110827T145431Z -> pkg://sfebuild/library/video/,5.11-0.151:20110830T210520Z
pkg://sfebuild/library/audio/,5.11-0.151:20110730T121940Z -> pkg://sfebuild/library/audio/,5.11-0.151:20110830T224537Z
pkg://sfebuild/media/,5.11-0.151:20110825T234711Z -> pkg://sfebuild/media/,5.11-0.151:20110830T214736Z
Services:
None
DOWNLOAD PKGS FILES XFER (MB)
Completed 3/3 278/278 7.6/7.6

PHASE ACTIONS
Removal Phase 15/15
Install Phase 38/38
Update Phase 268/268

PHASE ITEMS
Package State Update Phase 6/6
Package Cache Update Phase 3/3
Image State Update Phase 2/2

PHASE ITEMS
Reading Existing Index 8/8
Indexing Packages 3/3
Deleting content cache

  1. Description:
    I got video output (when playing sample). Audio not available in any case (tried video, mp3, radio stream)

Program started with: vlc &
VLC media player 1.1.11 The Luggage (revision exported)
[8154628] main interface error: no suitable interface module
[8063040] main libvlc error: interface "globalhotkeys,none" initialization failed
[8063040] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

GUI starts, i am opening file, it 'plays' but nothing gets out... (mplayer produces sound on same box). When exiting it creates core dump.

ls al /var/cores/core.vlc.uid101.13103\@1314780904
-rw------
1 root root 90M 2011-08-31 10:55 /var/cores/core.vlc.uid101.13103@1314780904

  1. Hardware
    $ pfexec scanpci | grep -i audio
    Intel Corporation 82801I (ICH9 Family) HD Audio Controller

$ pfexec modinfo | grep -i audio
163 fffffffff8818000 5d1b0 283 1 audio (Audio Framework)
235 fffffffff8b71000 b648 260 1 audiohd (AudioHD)

  1. Library:
    ldd /usr/bin/vlc
    libvlc.so.5 => /usr/lib/libvlc.so.5
    libvlccore.so.4 => /usr/lib/libvlccore.so.4
    libpthread.so.1 => /lib/libpthread.so.1
    libc.so.1 => /lib/libc.so.1
    libgcc_s.so.1 => /usr/gnu/lib/libgcc_s.so.1
    librt.so.1 => /lib/librt.so.1
    libm.so.2 => /lib/libm.so.2
    libresolv.so.2 => /lib/libresolv.so.2
    libsocket.so.1 => /lib/libsocket.so.1
    libiconv.so.2 => /usr/gnu/lib/libiconv.so.2
    libnsl.so.1 => /lib/libnsl.so.1
    libmd.so.1 => /lib/libmd.so.1
    libmp.so.2 => /lib/libmp.so.2

$ crle

Configuration file [version 4]: /var/ld/ld.config
Platform: 32-bit LSB 80386
Default Library Path (ELF): /lib:/usr/lib:/usr/mysql/5.1/lib/mysql:/usr/sfw/lib
Trusted Directories (ELF): /lib/secure:/usr/lib/secure (system default)

Command line:
crle -c /var/ld/ld.config -l /lib:/usr/lib:/usr/mysql/5.1/lib/mysql:/usr/sfw/lib

Screenshot-BodoWartke-Liebeslied.mp3_-_VLC_media_player.png - GUI running screen shot (14 kB) Predrag Zečević, 08/31/2011 09:02 am

dbx.vlc.zip - pfexec dbx /usr/bin/vlc /var/cores/core.vlc.uid101.13103\@1314780904 output (1.3 kB) Predrag Zečević, 08/31/2011 09:02 am

DELL-Vostro-400.zip - dmidecode from my PC (no zones, IO runs in global zone) (3.3 kB) Predrag Zečević, 08/31/2011 09:02 am

History

Updated by Alex Viskovatoff over 2 years ago

  • Status changed from New to Feedback

That's strange. vlc is stable for me as far as I can tell, and can certainly play mp3 files. The only difference between your environment and mine that I can see is that I have an nVidia audio controller.

But I tried vlc inside a fairly fresh install of OI inside VirtualBox and I still could not reproduce this problem. When I switched vbox to emulate the Intel sound card, the sound got garbled, but vlc did not crash.

Unfortunately, dbx couldn't obtain any useful information from the core dump. I don't know why.

Updated by Predrag Zečević over 2 years ago

Then,
this looks to me as broken audio driver for:

Intel Corporation 82801I (ICH9 Family) HD Audio Controller

(that can explain why i can't make sound working in VirtualBox guest)

Thanks for looking at ...
Regards.

Updated by Alex Viskovatoff over 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee set to Alex Viskovatoff

I erroneously gave SFEmpg123 the IPS package name libmad and built it using the wrong name. (There is no libmad 1.9.0 version.)

pkg uninstall -r libmad
pkg install vlc

should fix the problem.

Thanks for reporting this. Please confirm that the problem goes away for you, since I was not able to reproduce it (evidently because I did not install the incorrectly named libmad package).

Updated by Predrag Zečević over 2 years ago

Hmm,

still no luck (tried also mp3 - no sound - no core dump), but:

vlc http://streaming.tdiradio.com:9111
VLC media player 1.1.11 The Luggage (revision exported)
[8155628] main interface error: no suitable interface module
[8063040] main libvlc error: interface "globalhotkeys,none" initialization failed
[8063040] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[aac 9195080] channel element 2.4 is not allocated
[aac
9192540] max_analyze_duration 5000000 reached at 5015510
[aac @ 9192540] Estimating duration from bitrate, this may be inaccurate
channel element 2.4 is not allocated
Input buffer exhausted before END element found
invalid band type
channel element 3.7 is not allocated
channel element 0.0 is not allocated
Segmentation Fault (core dumped)

Updated by Alex Viskovatoff over 2 years ago

  • Priority changed from Normal to Low

Thanks for the feedback. I do not use VLC and I do not maintain this spec, so it is hard for me to get an idea of what is going on here.

As I understand your last post, I take it that the original problem is not resolved for you, in that even though VLC doesn't crash anymore when you try to play an mp3, you still have no sound.

VLC produces sound for me, so if it doesn't produce sound for you but doesn't crash, I suspect there is something wrong with your VLC configuration.

In addition you have run into another bug, that trying to play aac streams produces a core dump. mpd plays aac streams fine, which is why I have changed the priority of this bug to Low.

Updated by Predrag Zečević over 2 years ago

Also,

mplayer runs fine. I just wanted to point to the problem that other people might as well have...

It can be that AudioHD driver on my box (DELL Vostro 400 is supposed to be supported) is somehow broken ...

Regards.

Updated by Predrag Zečević over 2 years ago

After latest update, it works:

$ pkg info pkg
Name: package/pkg
Summary: Image Packaging System
Description: The Image Packaging System (IPS), or pkg(5), is the software
delivery system used on OpenSolaris systems. This package
contains the core command-line components and depot server.
Category: System/Packaging
State: Installed
Publisher: openindiana.org
Version: 0.5.11
Build Release: 5.11
Branch: 0.151.1
Packaging Date: September 12, 2011 03:13:38 AM
Size: 5.27 MB
FMRI: pkg://openindiana.org/package/,5.11-0.151.1:20110912T031338Z

Updated by Alex Viskovatoff over 2 years ago

  • Assignee deleted (Alex Viskovatoff)

So sound works with vlc now?

I take it the only problem you have left is the the one in the title, that vlc dumps core. It does that for me too, but it is not a major problem, since it only does that when I quit (not that I have tested vlc much).

Updated by Predrag Zečević over 2 years ago

Hi,

yes, it works. And yes, it segfaults on exit (not always, but mostly).
Thanks and regards.

Updated by Ken Mays over 2 years ago

  • Due date set to 2011-09-29
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • Estimated time set to 8.00
  • Difficulty changed from Medium to Expert
  • Tags changed from needs-triage to vlc

Thomas Wagner handles the VLC spec, and the current working package is: media/,5.11-0.151.1:20110914T122752Z

Based on the ticket feedback given, this VLC implementation passes with
normal DVD and MP3 audio playback on certain systems based on audio driver stability.

Let us migrate these talks to Bug #1499 to review other crash-related issues.

Also available in: Atom PDF