Project

General

Profile

Actions

Bug #14409

open

Graphical glitches in Pluma text editor make it unusable

Added by Niklas Poslovski 4 months ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

I experienced some really heavy graphical glitches in the Pluma text editor today when I tried to edit a config file.
I'm running the latest OpenIndiana Hipster version with all updates installed (ran pkg update and then tried to reproduce the issue,still exists).
Sometimes a picture says more than 1000 words,so I attached two screenshots where you can see the problem.
The first one happens when I remove the % in front of the lines,it looks like the view is redrawn without deleting the old view,so I see everything doubled.
The second one happens when I try to scroll up and down in the document,after having made the changes to the file mentioned before.
If I try to scroll up and down without having made any changes to the text file,it works perfectly fine.
I'm running OpenIndiana on a pretty standard Office computer which is a few years old,here are the specs if that matters:
CPU: AMD A4-5300 APU with Radeon(tm) HD Graphics, 2-core
Memory: 8G (8G); 8G maximum
Video: Advanced Micro Devices, Inc. [AMD/ATI] Trinity 2 [Radeon HD 7480D]
I got the hint in the IRC that it may be related to some libraries Pluma uses and not Pluma itself,but I could reproduce this bug so far only in Pluma,not any other GTK applications.


Files

pluma-bug-1.png (205 KB) pluma-bug-1.png Niklas Poslovski, 2022-01-16 11:07 AM
pluma-bug-2.png (1.2 MB) pluma-bug-2.png Niklas Poslovski, 2022-01-16 11:07 AM
Actions #1

Updated by Tim Mooney 4 months ago

Hi Niklas!

Thanks for the report.

What theme are you using? Do the graphical issues happen if you switch to something like 'nimbus' or 'nimbus dark'? I'm not suggesting you have to permanently switch to those, just wondering if you experience the same issue if you try one of those themes.

We've had one other person describe something pretty similar on the mailing list, and in their case, it was (partially) related to the theme.

One thing that changed in this version of pluma is that it's the first MATE component that updated to use 'gtksourceview-4'. Any other MATE component that uses the 'gtksourceview' library is still using 'gtksourceview-3' (which is deprecated and no longer receiving updates). GTK+ has a lot of themes, but not all of them have been updated as things in the library have been changed and deprecated.

Please give some other themes a try, and update this ticket if you can determine if a different theme works better (or if changing themes doesn't make any difference).

Actions #2

Updated by Niklas Poslovski 4 months ago

I use the default theme Nimbus.
I tried it again with all other preinstalled themes and it works fine in all of them,except the default Nimbus.
Even the other Nimbus variants Dark Nimbus and Light Nimbus work fine.

Actions #3

Updated by Tim Mooney 4 months ago

Thanks Niklas for that info, and for going the extra mile and being so thorough with checking the other themes!

It sounds like it may be necessary to do some comparisons between the standard theme and the dark & light versions, to see if it is possible to identify what needs to be updated with the standard theme.

I'll bring it up with the OI maintenance team, to see if there's anyone more experienced with Gtk+/themes than I am. If not, I'll put it on my list to look into. Since there's a workaround it won't be at the top of the list, but since Nimbus is our current default, it really should get fixed.

Thanks again for the report and for the info you've provided.

Tim

Actions #4

Updated by David Stes 4 months ago

I noticed also display update problems with "pluma" on my OpenIndiana system.

I was opening pluma, typed "poezie" and the characters were displayed incorrectly (with vertical bars, incorrect drawing).

Perhaps this is an irrelevant remark but I then enabled the Input Manager (IM) using the preferences -> Other -> Input Method Selector selected "ibus" and applied. I logged out, and logged in again and now ligthdm has created a .config/ directory with ibus and ibus-daemon --xim is running.

Strangely when I open pluma now, and type "poezie" it displays fine, no problem ...

Actions #5

Updated by Niklas Poslovski 4 months ago

Thanks for the hint.
I can confirm that enabling IBus fixes the problem.

Actions #6

Updated by David Stes 4 months ago

Perhaps enabling ibus is a workaround for now, but it should - as far as I know - not be necessary to enable ibus.

Actions #7

Updated by David Stes 4 months ago

When running pluma under "twm" (the basic, tab window manager) instead of MATE (lightdm), pluma also works fine for me, even without "ibus". Perhaps what we're seeing here is that when changing theme or enabling "ibus", there is a change of 'font'. If this is font metric related, it could be that changing the font fixes the issue. I see that in "twm" it displays fine, but it also uses a different font than the font used by default in lightdm default theme.

Actions

Also available in: Atom PDF